Question about Ford F-250

1 Answer

Some dash lights on my 01 ranger don't work.the bulbs are good

The lights for half of the speedo not working as well as the oil pressure, amp,& gas gauges.headlight & 4x4 switchs not working.at one point i could tap hard on the top of the dash or the gauge lens & some of the lights would come back on but that dosen't work anymore. also the cruse control engaged indicater light doesn't work

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 11 Answers

Get an Auto Electrician to trace and fix the problem. There are partial contacts in the wiring system.

Posted on Dec 29, 2012

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
mcgyver468
  • 710 Answers

SOURCE: started out with headlights out then the speedometer, odometer, gas gauge, oil, battery, rpm's are not working, fixed the headlight was a fuse but other stuff still won't work.

sounds like your missing a ground somewhere.

Posted on Apr 21, 2009

  • 1 Answer

SOURCE: Toyota Hilux rev gauge,radio,windscreen wipers,oil gauge stopped

check fuses first

Posted on Feb 19, 2009

  • 2 Answers

SOURCE: Dash lights don't work

did you check for loose connections in the wiring harness, fuse box, or fuses?

Posted on Apr 07, 2009

  • 412 Answers

SOURCE: Instrument cluster on 97 Wrangler

IF YOU REMOVE INSTRUMENT CLUSTER AND UNPLUG IT,PLUG IT BACK IN AND UNPLUG IT AGAIN..DO THIS A FEW TIMES..IT SHOULD CLEAN OFF SLIGHT OXIDATION ON CONNECTOR TERMINALS..HAVE SEEN THIS BEFORE..I ALSO THINK REPAIR CONNECTORS AVAILABLE FROM DEALER

Posted on Jun 21, 2009

  • 973 Answers

SOURCE: Everything works fine on my vehicle EXCEPT today

Check the fuse for those items that don't work.

Posted on May 28, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

98 Ranger Headlights Not Working


Check the bulbs, if OK replace switch.

May 17, 2017 | 1998 Ford Ranger SuperCab

1 Answer

Certain dash lights don't light up


Probably bulbs in the dash cluster burnt out, or possible bad printed circuit. Pull the guage cluster and check illum. circuit for the right bulbs

Oct 04, 2012 | 2000 Chrysler Concorde

1 Answer

2004 gmc denali: backlit dash lights do not work


Check your bulbs first, I have lost both headlights on my ford at once on account of the bulbs burning out at the same time. Same thing probably happen, you have one filament out. The lights can work, but if the filament for brake is burnt, you don't see brake lights.

Sep 12, 2012 | Cars & Trucks

1 Answer

I hooked up an after market stereo and now my speedometer lights don't work. Know why? On my 01 echo.


the bulb could have been bad, yet the aftermarket stereo wiring takes voltage from your dash, hence the illumination/dimmer. really dont need those wires. they hook up to your dash lighting, and draw power from your dash, take those wires out and see if any changes. Id first take the wires out, if no change then the bulbs are probably bad.

Jun 08, 2011 | 2001 Toyota Echo

1 Answer

I did a full tune up ( plugs, oil, and oil filter) on my 01 GTI VR6 and it ran fine for mabey half an hr and then my oil light started flashing and on the dash, it said to turn the car off. I checked the...


If you have an oil pressure sensor light that keeps coming on even, if you have just filled up your oil tank to the optimized level, then there's a good chance that it's the oil pressure sensor that's not working. If the light sensor is coming on and off while you are driving, it's most likely a faulty oil pressure sensor. But to make sure, always check your oil tank whenever the light comes on again. If the oil level is still up to the desired level, then it's definitely an oil pressure sensor. This calls for an oil pressure sensor replacement, which is far better than having an engine repaired. It will only cost a couple of bucks to replace a sensor. if above fails, have the oil pressure checked it could be a plugged up oil pump. have a good day !! check the wiring to sensor also.

May 24, 2011 | 2001 Volkswagen GTI

1 Answer

No dash lights e300 1994


try your dimmer switch on the instrument cluster. that unit is just a variable resistor and they are a comman failure. by sliding your instrument cluster out you can gain access to the dimmer switch from the rear of the cluster(just be careful of your oil pressure line that attatches to the back of the oil gauge because if it is damaged it will squirt oil all over your interior when the vehicle is started. good luck

Apr 01, 2009 | 1994 Mercedes-Benz E-Class

2 Answers

Oil pressure gauge on wrong side of pin


pull the cluster out an slip a wire between the clear plastic an just flip the needle back up...i just did this yesterday lol works great now

Mar 08, 2009 | 2002 Ford Ranger Regular Cab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

193 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

Marvin
Marvin

Level 3 Expert

85161 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

gerry bissi

Level 3 Expert

4387 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...