Question about Mercedes-Benz S-Class

Open Question

My 1995 mercedes s420 stalling after a few miles so i changed cam sensor on front of engine ,didnt find another sensor i thought there were 2 changed 1 but still does the same but stays on longer

Is there a fuse that goes with out with sensor

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
ilragatzzo78
  • 241 Answers

SOURCE: knock sensor

The knock sensor threads into the side of the cylinder block.

  1. Disconnect electrical connector from knock sensor.
  2. Use a crow foot socket to remove the knock sensors.
INSTALLATION
The knock sensor threads into the side of the cylinder block in front of the starter.

  1. Install knock sensor. Tighten knock sensor to 10 Nm (7 ft. lbs.) torque. Over or under tightening effects knock sensor performance, possibly causing improper spark control.
  2. Attach electrical connector to knock sensor

Posted on May 15, 2008

Ad
micromaster
  • 3614 Answers

SOURCE: 1995 accord LX engine shakes when starting

have you try cleaning also the air filters..? fuel pump..?

Posted on Jun 18, 2008

  • 203 Answers

SOURCE: the asr light is on and the car does not

the o2 senser would not cause the a.s.r. light to come on-there is only 2 things that the engine module and the a.s.r. module have in common. 1 is the e.a. actuater(throttle) and 2 is the base module. most likley either your acuater has to be resynchronized or the actuater itself is bad. have codes pulled from your h.f.m.,a.s.r.,e.a-i.s.c.-c.c modules and see what the codes say. You will probably find that they say e.a. actuater module is defective. the pig tail connecters go bad and they need to be replaced just be glad you do not have a 600 series because they cost about 1200 a piece and the v12 have 2 of them. If it is defective and you cannot resynchronize it there is a company that rebuilds them for about 1/3 the cost of a new one- good luck

Posted on Jun 17, 2009

  • 94 Answers

SOURCE: 02 PT Cruiser LE w' Code P0340

My thought is to get a refund from the shop that tried to replace parts in order to secure your problem. The job of the shop is to diagnose the problem, not to replace items that may be the problem. Chrysler Master Techs are not trained to just replace parts, they fix the problem by diagnosing it properly.

You need to see a Chrysler dealership so they can attach a DRBIII and tell you exactly what is at stake.

I hope this helps you. I would be mad as heck.

I would not think the plugs and wires would be the problem because they would all have to fail at the same time to provide the symptom you experienced.

1. Get your money back
2. DRBIII

Posted on Jul 11, 2009

Wood Chuck
  • 34 Answers

SOURCE: 1995 CHEVY VAN 20 305 WONT IDLE

Check your fuel pump presure. Pump is in the tank. Also try and loosen the fuel cap, the tank vent may be stopped up.

Posted on Sep 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

MY MBENZ S420 1995 V8 MODEL IS GIVING ME PROBLEMS , IT STARTS BUT TAKES A LOT OF FUEL AND THE SOUND IS BURIED INSIDE. IT DOES NOT MOVE SMOOTHLY.


Probably a lot more thing you could change throttle body, MAF, sensor, plug wires and many other thing.
You would help yourself by finding out what codes are present if you have a check engine light. If you do not have check engine light I would make sure there are none before spending any more money.
Where I live most auto parts store will check your codes for free.

Sep 23, 2018 | Mercedes-Benz S-Class Cars & Trucks

1 Answer

Cam sensor location


im sure the timing cover at front of the engine
http://www.importecwarehouse.com/Mercedes-Cam-Camshaft-Position-Sensor-Front-of-Eng-p/mb0021539528.htm

Mar 11, 2014 | Cars & Trucks

1 Answer

What's the firing order for the s420 MB 4.2L?


3ac03556-8586-4127-8ab4-0f1cbe44e978.gif
this should help, on the sides you have the piston #, and at front you got the firing order

Mar 05, 2014 | 1995 Mercedes-Benz S-Class

1 Answer

Oil llight comes on but oil is full 1995 S420


faulty oil level sensor or wiring for oil level sensor, it's fitted at underneath the oil pan near the drain plug it's mounted to the oil pan by three bolt if you going to remove it you must drain engine oil first before remove the sensor, is this information helped you?

Oct 26, 2010 | 1995 Mercedes-Benz S-Class

2 Answers

How do I remove the front bumper cover on a 1995 Mercedes S420


Under the front of the car on the engine compartment should be nuts that you can remove to remove the cover.

Aug 02, 2010 | 1995 Mercedes-Benz S-Class

1 Answer

My 1995 mercedes S500 idles rough, and no power. Smells terrible of fuel. Sputters on acceleration. Check engine light came on . Acts as if to stall but keeps sputtering. Literally shakes the car.


I had a similar problem with my 1994 S420.
Before taking it to the shop check the following:
Distributor covers, Rotors and Spark Plugs. That's what my car needed. Before I did it two "specialized" MB mechanics wanted to replace the engine wiring harness ($1,000.00) and the other wanted to replace Air mass sensor, throttle valve actuator ($2,000.00) I hope that's all you need.

Dec 11, 2009 | 1995 Mercedes-Benz S-Class

1 Answer

Keeps stalling on me and runs really really rough


THe coolant sensor could be the culprit. It may be stuck in advanced mode or even cold mode causing it to stall at lights. The sensor may have been over tightened. These sensors need to be put in with a minimum of torque, just enough to avoid leaking. Without seeing the car this is the first place I'd look. Thanks for your question.

Sep 15, 2009 | 2001 Dodge Durango

1 Answer

1995 gmc jimmy-won't accelerate wants to stall


could be the fuel pump ...you will need to do a fuel pressure test on it ..the pressure should be 63 anything lower even so much as a few lbs will cause this to happen ...as well if it sat that long i would consider a complete tune up and check all vacuum lines for dry-rot


Sep 14, 2009 | 1995 GMC Jimmy

2 Answers

1995 Mercedes S420 Power Steering Pump


it is locates on the left side of the engine block by the distributor cap,if ur car engine is the 119.971 .140 body style

Apr 22, 2009 | 1994 Mercedes-Benz S-Class

1 Answer

1995 accord LX engine shakes when starting


have you try cleaning also the air filters..? fuel pump..?

Jun 18, 2008 | 1995 Honda Accord

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

13 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Marvin
Marvin

Level 3 Expert

85178 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...