20 Most Recent Ultra Linear UL-2200D Car Audio Amplifier Questions & Answers


The power antenna wire only supplies 12vdc when the radio is on. When CD or other sources are selected, the power antenna wire goes to 0vdc. The remote turn-on wire provides 12vdc whenever the head-unit is on. If your amps are powered on only when the radio is turned on, I would bet that you have the power antenna wire connected and not the remote turnon wire.

Ultra Linear... | Answered on Dec 13, 2018


Seems that the output stages of amp are blown and it shuts down for self preservation. When you do a lot of blasting amp failure is common especially if you use an equalizer to "soup things up." If you are blasting along at 1000 watts and you add 3 db of boost at a frequency the amp will double the power at that point, If you go up 6 db now the power is up to 4000 and exponentially. And transistors are not like tubes that know their limits.- given the chance they will simply blow themselves away providing power they do not have! You have to be careful at high volume levels.

Ultra Linear... | Answered on Sep 06, 2017


You say you have 2 p312d2 subs. Ok so the d2 stands for dual 2homs (2 X 2homs voice coils per sub) , conecting in parallel the 2 voice coils of only one sub will create 1hom load to the amp, and if your amp is 2homs stable per chanel that means you are lowering too much your homs causing the overhwating to it.

Ultra Linear... | Answered on Oct 21, 2015


Sounds like you have a weak signal on remote wire. If tou placed a jumper your amplifier is staying on.

Ultra Linear... | Answered on Nov 25, 2014


Use a test light or Multimeter to verify that you have at least 12volts on your remote wire as well as your Power cable.

Ultra Linear... | Answered on Nov 24, 2014


Please give more details. When does it cut off? Is it hot?

Ultra Linear... | Answered on Nov 24, 2014


You can start by trying a new fuse, use the correct fuse for your amp. If the fuse is blown, you can look at it and see the middle is burnt connecting the two sides.

Ultra Linear... | Answered on Nov 25, 2010


yes always make sure you have a good ground

Ultra Linear... | Answered on Aug 12, 2010


hook up the power lead to a switched circuit from the ignition or install a toggle switch

Ultra Linear... | Answered on Apr 28, 2010


is your amp mounted in a place where there is little space around it? it needs to be able to circulate air properly, so make sure theres nothing covering it up. also, make sure you are speakers are wired to at least a 4 ohm load. if its any lower, it will build up too much heat. let me know what kind of speakers you have connected and how many, and ill tell you how to get it to the proper ohm load.

Ultra Linear... | Answered on Mar 06, 2010


YOUR METHOD OF TROUBLESHOOTING USING THE PROCESS OF ELIMINATION IS RIGHT ON AND PERFECT. IT INDICATES A BAD AMPLIFIER CHANNEL. I KNOW THIS SOUNDS ODD, AS YOU HAVE TWO OF THESE NOW. IT IS RARE, BUT I HAVE SEEN INPUT CONFIGURATION SWITCHES WIRED BACKWARDS, SO THE ONLY THING LEFT TO DO IS TO HOOK UP THE BAD CHANNEL TO ONE SPEAKER ONLY, BY ITSELF. THEN TAKE ONE RCA ONLY AND PLUG IT INTO ONE RCA INPUT AT A TIME. THEN MOVE THE INPUT SWITCHES AND REPEAT THIS PROCEDURE UNTIL YOU HAVE TRIED ALL SWITCH COMBINATIONS AND ALL INPUT JACKS. WHAT YOU ARE TRYING TO DO AT THIS POINT IS TO DETERMINE IF THERE IS ANY RCA JACK WITH ANY SWITCH POSITION, THAT WILL ALLOW YOU TO GET OUTPUT FROM THAT CHANNEL. IF AFTER THIS TEST, YOU STILL HAVE NO OUTPUT, THEN NO MATTER HOW ODD, IT WOULD INDICATE THAT YOU DO IN FACT HAVE A SECOND DEFECTIVE AMPLIFIER. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

Ultra Linear... | Answered on Jan 06, 2010


what ohm is it running at? if you have all three hook up it parallel then its to low of ohms and it would be louder if you unhook your 10" sub as it moves differently form the 12"s and it cancels out some bass. but if you want it then you have to change the wiring around a bit. take the positive wire off a 12 and put it on the positive side of the 10 and then take the ground for the 10 and hook it up to the positive side of the 12. so you should have one wire from the amp going to the negative side of the 12 and one going to the positive side of the 10 and a jumper wire from the 10 to the 12. and if it still shuts off then you have bigger problems.

Ultra Linear... | Answered on Sep 25, 2009


its a pretty simple principle...combine 2 speakers, and the ohm load gets cut in half. wire them in a series, and the ohm load doubles. for example, you have 2 subs that are 4 ohms a piece. if you combine both + and both - and put them to the amp, it cucts the load in half bringing it to 2 ohms. or, if you connect 1 + to the other speakers =, then run the remaining pair of wires to the amp, that doubles the load to 8 ohms. youll have to "double-ohm" it for dual voice coil subs. on each sub, you can do the same thing. either combine both + and both = into 1 wire to cut the rated load in half, or wire them in a series to double the load by connecting a + to the other coils =, and using the 2 remaining wires. once you have each sub wired the way you want it, then you can use the same rules when connecting multiple subs, by wiring in a series or parallel. it sounds confusing and its hard for me to put into works, but once you do it a few times its really easy. just remember the 1 rule...wire 2 coils parallel to cut the coils load in half, and wire it in a series to double it. hope it helps.

Ultra Linear... | Answered on Sep 08, 2009


your sub/s are drawing to much power adjust the bass boost

Ultra Linear... | Answered on Aug 25, 2009


If you run the remote from the battery you will need a on/off switch. Sounds like the amp is overheating. Also, I don't understand bridge the remote and power. They should be seperate going into the amp.

Ultra Linear... | Answered on Aug 09, 2009


Hello pumpin_up_da,

The most likely cause for the problem you describe is that the remote turn-on lead to the amp is functional only when the head unit is operating in tuner mode. This could be caused by using a power antenna lead instead of a remote lead. Some head units have both, some only one or the other. Check the wire going to the amp remote terminal with a voltmeter. If it shows 12V when the radio is operated in tuner mode but 0V when you switch to CD, then check the wiring. If this is the cause, and your head unit has a dedicated amp turn-on lead, then connect it to the amp terminal. Most head units that have both power antenna and remote leads code them "Blue" and "Blue/White". If your head unit does not have an amp turn-on lead, you need to wire it to a 12V switched source, usually the "red" wire on most aftermarket receivers. You can then put a SPST toggle switch (available at Radio Shack or most auto parts stores) in line with the wire and turn it on and off as desired.

If the correct wire from your head unit is currently connected, then the receiver is defective and needs repair or replacement. Or, if everything else still functions normally, and really don't want to bother with repair or replacement, you can still use the 12V switched source as described above.

Hope this helps.

Ultra Linear... | Answered on Jul 09, 2009


look around the power input on the amp on the inside and wiggle the capacitors around to see if any of the legs burned up because sometimes the tops don't pop up instead they burn the leg off and just so that u know that amp is not stable at 2 ohms only 1 ohm

Ultra Linear... | Answered on Jul 06, 2009


IF THE AMP IS BRIDGEABLE, THEN BRIDGE THEM. IF NOT THEN RUN THEM MONO. THE TYPE OF VEHICLE HAS ALOT TO DO WITH HOW TO HOOK THEM UP.

Ultra Linear... | Answered on Feb 24, 2009

Not finding what you are looking for?
Ultra Linear UL-2200D Car Audio Amplifier Logo

27 questions posted

Ask a Question

Usually answered in minutes!

Top Ultra Linear Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

93 Answers

FastHarley
FastHarley

Level 3 Expert

746 Answers

brian williams

Level 3 Expert

1719 Answers

Are you an Ultra Linear Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Ultra Linear Car Audio & Video

  • Ultra Linear Car Audio & Video

Most Popular Question

pioneer gm 7300 amp getting hot shutting

  • Car Audio & Video
Loading...