Question about Texas Instruments TI-83 Plus Calculator

1 Answer

No display at all, does not seem to be turning on, yes I replaced the batteries.....any thoughts?

Posted by on

  • gardenslilly Sep 12, 2011

    I Have dont all of the above...............does not work.......

    A guaranteed refund please..............

    Thank you.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 6,993 Answers

Hello,

If new batteries did not solve the problem, the next thing to check would be the battery terminal.

If the battery terminal is rusty, the battery power won't contact and the calculator won't turn on. So, use a flat small screw drive to scratch the battery terminal so that there would be contact.

If the above is not the problem, the next to check would be the wire connecting the battery terminal to the the calculator's main board. There is a wire between the battery terminal and the calculator board. When the battery is inserted, the power from the battery goes from the terminal to the board through this wire. There is a possibility that this wire is cut in-between or is loosing contact. In this case, you need to get a small screw driver and carefully disassemble the calculator in order to check the wire.

If the wire is intact, use a light brush to brush the calculator board as there might be dust on the board.

If non of the above helps, then it means the calculator is dead and needs a replacement.

Regards.

Posted on Sep 12, 2011

  • Walesarumi
    Walesarumi Sep 12, 2011

    How did the problem begin with the calculator? And when last did you use it before it got damaged?

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Replacement batteries do not seem to be charging. Have checked they are the right sort of batteries. What am I doing wrong!?


The assumption is you replaced the batteries because you thought they were bad. It's highly possible the charger of your base is dead. If you have a voltmeter see if there's voltage (10% or more greater than the rated voltage of the battery). If not, it's the charger that's dead, not the batteries.

Nov 29, 2014 | Lands Phones

1 Answer

Altea 4 mobility scooter battery problem


hi, the battery's sound okay, have you made sure the scooter not in free wheel mode ? check the lever attached to the side of the brake ,,,

Check the wiring going to the axle .. At worse the controller has called it a day...at best a loose connection,,, controllers are repairable..

Regards
Rob

www.gewizrepairs.co.uk

Apr 20, 2014 | Pride Mobility Products Health & Beauty

2 Answers

My 2008 impala has a "flicking"problem with the


I'd check your grounds from battery to block make sure they are tight and not corroded.

Oct 17, 2011 | 2008 Chevrolet Impala

1 Answer

THe ding dong was sounding "sick" like the batteries were low so I replaced them and now there is no sound at all - and yes the batteries are installed correctly. THought perhaps I needed to replace the...


Might have bad battery connections,do to rust or moistures.Take some cotton balls,dips it in with some rubbing alchahols,clean all the battery connections.Wait like half an hour,reintall the battery,see what happens.

Oct 12, 2010 | Desa International White Wireless Plug In...

1 Answer

A/c in front did not show read out on the thermostat this am. I thought it had been turned off. I checked the switch, turned it off and then back on and the numbers etc. came up but then it went blank...


depending on the brand of digital tstat usually when the display A/C it usually means that you lost control power to the tstat if the tstat has batteries in it pull the batteries out and display goes blank then there is no control voltage depending on the unit most have a fuse in the inside air handler newer units use a flat automotive 3 or 5 amp fuse same as a car. if you replace fuse and blows again there is a elsctical short

Jun 04, 2009 | Heating & Cooling

2 Answers

Epson P-2000 won't work on battery power


yes, the p-2000 is basically a pile of ****. epson dont do repairs, but offer a replacement for £170! rubbish product, rubbish company, no support! bin it - my second has done the same.... junk!

Mar 17, 2008 | Epson PhotoFine P-2000 Digital Media...

1 Answer

Battery Charge Light not working & can't display battery info


This sounds similar to a problem I had. I brought the camera in under warranty and the repair shop fixed it. They shop text is cryptic.
Problem: Camera light keeps flashing, not charge
Solution: Troubleshoot to intermittent switch block control, replace with new one, test OK.

Dec 29, 2007 | Sony Handycam DCR-HC20 Mini DV Digital...

Not finding what you are looking for?
Texas Instruments TI-83 Plus Calculator Logo

Related Topics:

135 people viewed this question

Ask a Question

Usually answered in minutes!

Top Texas Instruments Office Equipment & Supplies Experts

k24674

Level 3 Expert

8081 Answers

Steve Allison
Steve Allison

Level 3 Expert

5569 Answers

Ekse

Level 3 Expert

13434 Answers

Are you a Texas Instruments Office Equipment and Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...