Question about Chevrolet 1995 Chevrolet Blazer S10/jimmy S15 Radio

Open Question

Its has a miss after it warms up

It runs great when you start it cold after it warms up it has a miss.the plugs,cap,wires are new i have changed out the sensors put a new egr on it so whats wrong with it

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 314 Answers

SOURCE: 98 chevy 1500 loses power

This sounds like the exhaust is the prob. My guess is the convertor! Frankster016

Posted on Oct 25, 2008

Ad
alicantecoli
  • 22484 Answers

SOURCE: 98 chevy 1500 loses power

sounds like an ECU fault.one of the chips is breaking down when the units warms up

Posted on Nov 04, 2008

  • 16 Answers

SOURCE: s10 pickup after warming up truck starts missing

You might have computer problems.

Does the check engine light come on when it starts to miss?


Posted on Nov 30, 2008

lovelle40
  • 26 Answers

SOURCE: 95 chevy truck 4.3 motor has like a miss in high gear after warms

The fault could be in the ingnition module in the dist.I had a car one time that did the same thing but when it was cold,try replacing the the ignition module.

Posted on Jan 02, 2009

  • 39 Answers

SOURCE: 98 Astro Van,when warm hesitating, stalling

WELL YOU CHANGED ALMOST EVERY THING EXCEPT IGNITION CONTROL MODULE........

Posted on Jun 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What is causing random misfire?


Fuel filter,vaccum leak,plug gap.

Mar 03, 2016 | Cars & Trucks

1 Answer

Cold start blazer


change your MAP sensor and clean the IAC valve

Mar 20, 2014 | 1994 Chevrolet S-10

2 Answers

Runs good until warm


I would suspect fautly spark plugs.

Dec 03, 2009 | 1987 Nissan Pathfinder

1 Answer

Runs poorly when warm, but great when cold


have you checked your o2 sensors?

Nov 25, 2009 | 1995 Isuzu Trooper

1 Answer

Hard Cold Start


if the check engine light is not on?do a tune up on it,cap,rotor,plugs and wires,fuel and air filter.

Apr 12, 2009 | 2000 Chevrolet Blazer

2 Answers

95 chevy truck 4.3 motor has like a miss in high gear after warms


The fault could be in the ingnition module in the dist.I had a car one time that did the same thing but when it was cold,try replacing the the ignition module.

Jan 02, 2009 | 1995 Chevrolet C1500

Not finding what you are looking for?
Chevrolet 1995 Chevrolet Blazer S10/jimmy S15 Radio Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Audio Players & Recorders Experts

D. E. Hev

Level 3 Expert

1187 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

Lawrence Oravetz

Level 3 Expert

10543 Answers

Are you a Chevrolet Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...