Question about HP ProCurve 4104gl Networking Switch

1 Answer

3 vlans, data,1; data 2,;voip,5. Ports carry voice tagged, and data. currently Windows 2000 DHCP server lives on Vlan 1 (AND WORKS). Need to upgrade. When we test the new servers we are unable to make both vlans, and voice to work correctly. Phones that share a port with vlan 2 data, don't get an voip IP address, they get the data ip address.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 339 Answers

Here's what you need to do:

First, be sure to assign an ip address(in the proper subnet) to each VLAN.

Second, use the ip helper-address command in the context of each VLAN, the address used should be the address of the DHCP server

Third, Add a scope for each additional VLAN on the DHCP server.

The switch will route the DHCP request to the proper server based on the ip helper-address command parameter and based on the ip address of the VLAN that is passed tot he server, a DHCP address in the proper subnet is automatically configured.

Here is a sample:

ProCurve Switch 3500yl-24G-PWR# configure
ProCurve Switch 3500yl-24G-PWR(config)# vlan 33
ProCurve Switch 3500yl-24G-PWR (vlan-33)#ip address 192.168.33.254/24
ProCurve Switch 3500yl-24G-PWR (vlan-33)# ip helper-address 10.1.2.250

Posted on Aug 08, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

How to configure VLANS and Tagging


https://m.youtube.com/watch?v=krE16IRIHw4
Watch this video for switch port access . You will need to be in global config interface mode.

Jun 05, 2016 | HP ProCurve Computers & Internet

1 Answer

I'm trying to setup vlan 1 for data and vlan2 for voice. help please...


This depends on what the devices are doing with VLAN tagging. In the switch settings you will want to add VLAN2 and make sure you set it to Fixed on the ports you want to allow VLAN2 to work on. VLAN1 is already configured for all ports.
If your devices are tagging the VLAN2 traffic but not the VLAN1 traffic you don't need to do anything. By default any incoming non-tagged traffic will be set to VLAN1. This is because the PVID is set to 1 by default. If you need the incoming traffic to be tagged with VLAN2 changed the ports PVID to 2.

Sep 13, 2013 | Zyxel ES-2108 8PORT 10/100BT MAN L2 SWITCH...

1 Answer

Sir I have 4200 series 26 ports Switch i want to Configure intra VLAN But I am Getting a problem to Configure that switch . After Cnfigure VLAN on Consol prompt. I am not accessing to my Server & WAN...


Hi,
If you are creating only Layer 2 VLANs on the switch , you wont be able to ping the servers and Routers as they are in default VLAN1.
you can do the below steps
1. Create sub interfaces on the router LAN interface
2. Provide a new ip range to the new sub interface
3. Make the switch port connecting router as trunk, so that it will carry both the VLAN info
4. on your Labtop/PC give the IP address in the newly defined range
5. Make your switch port to be in the new VLAN

This will work , if you wont be able to configure the above settings, let me know i will give you the detailed config

Nov 01, 2010 | 3Com 4500 24-Port Ethernet Switch

1 Answer

Hi,this is pavan i want to b configure the HP procurve 2626 J4900B managed switch pls help me through anybody by giving the programme to configure it


What do you need it configured to support? Multiple subnets? VoIP support?
Here's an example to support 2 subnets, VLAN 1 Data and VLAN 2 Voice. This switch is the VLAN router for the site and it is also the default gateway for all the devices on the network.

show running-config

Running configuration:

; J4899A Configuration Editor; Created on release #H.10.50

hostname "HP 2650 dot 11 layer 3"
snmp-server contact "Your contact info here"
snmp-server location "Server Rack - Upper Switch"
time timezone -5
time daylight-time-rule Continental-US-and-Canada
interface 49
name "Uplink to HP2650 port 49 - 192.168.105.12"
flow-control
exit
interface 50
name "Uplink to HP2650 port 49 - 192.168.105.13"
flow-control
exit
ip routing
timesync sntp
snmp-server community "public" Unrestricted
vlan 1
name "Data"
untagged 1-46
ip address 192.168.105.11 255.255.255.0
ip helper-address 10.50.3.2
tagged 49-50
no untagged 47-48
exit
vlan 2
name "Voice"
untagged 47-48
ip address 10.50.3.11 255.255.255.0
ip helper-address 10.50.3.2
tagged 1-46,49-50
exit
ip route 0.0.0.0 0.0.0.0 192.168.105.1
spanning-tree Always turn on Spanning Tree
spanning-tree priority 0 This switch is the master Spanning Tree operator.
password manager
password operator

Sep 20, 2010 | HP ProCurve 2626 (J4900B) 24x10/100 Mbps...

1 Answer

7940G IP Phone: how to solve the protocol application invalid prob...


Hi

This happens when you IP phone communicated with the Voice vlan with the IP address of data vlan.

To solve it manually enter the IP address of the TFTP server and option 150 on the DHCP server.
remove the voice vlan from the switch port and reboot the phone
again add the voice vlan and reload the phones

May 17, 2010 | Cisco 7940G IP Phone

1 Answer

I need to config a hp procurve 2610 with a data and voice vlan to work with my mitel.


hostname "Switch1"
qos dscp-map 101110 priority 6
snmp-server community "public" Unrestricted
vlan 1
name "Data_Vlan"
untagged 1-28
ip address 192.9.180.19 255.255.255.0
exit
vlan 2
name "Voice_Vlan"
ip address 10.9.180.5 255.255.255.0
qos dscp 101110
tagged 1-28
voice
exit
Program the port that the PBX is in as a untagged port on Vlan 2

Nov 30, 2009 | HP ProCurve 2626 (J4900B) 24x10/100 Mbps...

1 Answer

ZyXEL IES-1000 with AAM1212 ADSL 12 port module step-by-step guid


Going through the GUI would take too long, so use CLI to add the commands below. After that, check the GUI and see how those changes appear.

VLANs:
On all equipment use 802.1q tagging. The example below puts adsl ports 1 to 10 in vlan10 and ports 11-12 in vlan2. These vlans are 802.1q tagged on the ethernet ports.

switch vlan set 1 1~12:X enet1~enet2:FT DEFAULT
switch vlan set 2 1~10:X 11~12:FU enet1~enet2:FT VLAN2
switch vlan set 10 1~10:FU 11~12:X enet1~enet2:FT VLAN10
switch vlan set 17 1~12:X enet1~enet2:FT VLAN17
switch vlan pvid 1~10 10
switch vlan pvid 11~12 2
switch vlan pvid enet1~enet2 1
switch vlan priority * 0
switch vlan gvrp * disable
switch vlan frametype * all
switch vlan cpu set 1

ATM circuit:
Each port requires one or more VPI/VCI circuit. You could map different circuits to corresponding vlans. The config below creates a primary circuit 1/35 on each port. On ports 5 and 9 is another circuit 1/32 mapped to vlan10

adsl pvc set * 1 35 super DEFVAL
adsl pvc set 5,9 1 32 10 0 DEFVAL

Remember a dslam is just a switch, bridging packets from a VC onto a VLAN or straight onto ethernet.

Mar 27, 2009 | Zyxel IP Express IES-1000 (91004098002)

2 Answers

IP Addressing by dhcp for vlans


tell each vlan about DHCP server using

ip helper <DHCP servers ip adddress>.

in config mode.

Mar 03, 2009 | Cisco Catalyst 2950 24x10/100 Mbps...

2 Answers

Sending DHCP request across diffrent vlans


Hmm... on your DHCP server, try setting the "default router" IP for each pool to be the VLAN ID on the switch.

scope 172.16.0.0 /24
router 172.16.0.1

scope 10.20.8.0 /22
router 10.20.8.1

I think the DHCP replies aren't going back where they should. I've never done this without a router doing all the DHCP, but it does work and i've done it many times. Your config looks spot on for the switch.

Feb 01, 2009 | Cisco Catalyst 3750E-48PD

Not finding what you are looking for?
HP ProCurve 4104gl Networking Switch Logo

1,553 people viewed this question

Ask a Question

Usually answered in minutes!

Top HP Computers & Internet Experts

Ekse

Level 3 Expert

13434 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18429 Answers

Thomas F. Schneider

Level 3 Expert

2715 Answers

Are you a HP Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...