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Hi,
The Display (LCD) need to be replaced.

RIM BlackBerry... | Answered on Dec 16, 2017


It needs to say "GPRS" or "EDGE" in the top right hand corner in captial letters. If there is lower case letters, this indicates the phone is having an issue with the data connection.

Have you been able to send/receive email whilst in the country you are in now?

Most obvious things first, remove the battery, then re-insert and reboot. This will reboot the phone and create a new connection to the Blackberry server. Let me know how that goes.

RIM BlackBerry... | Answered on Dec 15, 2017


It may just be time to get a new phone. I didn't even know that BlackBerry phones were still around.

RIM BlackBerry... | Answered on Dec 12, 2017


hi Titchypink.
this is all i could find out,hope it helps you out.
Trackpad, trackball, or keyboard not working on a BlackBerry smartphone running BlackBerry OS 7.1 and earlier Article Number: 000029640 First Published: April 26, 2017 Last Modified: April 26, 2017 Type: Support

Environment

  • BlackBerry smartphones running BlackBerry OS version 6 to 7.1
  • BlackBerry smartphones running BlackBerry Device Software 5.0
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Overview

In some situations, a BlackBerry smartphone with a trackpad or trackball may experience issues with sensitivity, latency, or scrolling. Additionally, the BlackBerry smartphone keyboard, or other buttons may be unresponsive.
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Cause

This issue might be caused by one of the following:
  1. The trackball/trackpad sensitivity needs to be adjusted.
  2. Make sure the trackball/trackpad is not affected by a software freeze or an application freezing.
  3. The BlackBerry Device Software is out of date and requires an update to resolve the trackpad, trackball or keyboard issue.
  4. The physical trackpad, trackball or keyboard hardware is malfunctioning.

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Resolution

Resolution for Cause 1
Complete the steps in Article 5447 to ensure the trackball/trackpad sensitivity is correctly.
Resolution for Cause 2
For BlackBerry smartphones running BlackBerry OS version 6 to 7.1 using a trackpad, complete the following:
  1. From the Home screen, select Options.
  2. Select Typing and Language.
  3. Select Trackpad Sensitivity.
  4. Ensure Audible Roll is selected.
  5. Rapidly roll the trackpad up, down, right, and left.
  6. If an audible click is heard while not responding, proceed to Resolution for Cause 4 as this could be a software related problem.
For BlackBerry smartphones running BlackBerry Device Software 5.0 using a trackball, complete the following:
  1. From the Home screen, select Options.
  2. Select Screen/Keyboard.
  3. Ensure Trackball Audible Roll is selected.
  4. Rapidly roll the trackball up, down, right, and left.
  5. If an audible click is heard while not responding, proceed to Resolution 4 as this could be a software related problem.
  6. If an audible click is not heard, the problem may be related to a hardware issue. Please contact the wireless service provider for additional steps.
If an audible click is not heard, the problem may be related to a hardware issue. Please contact the wireless service provider for additional steps.
Resolution for Cause 3
To update BlackBerry Device Software using BlackBerry Desktop Software see, Article 11320.
or
To update the BlackBerry Device Software on the BlackBerry smartphone visit http://www.blackberry.com/update/
Resolution for Cause 4
Use the BlackBerry Virtual Expert diagnostics application. For more information, see Article 35973.if not try this link. blackberry scroll pad is not working Google Search

RIM BlackBerry... | Answered on Nov 27, 2017


Try lowering the light of your phone and maybe you overcharged it, which is sometimes the cause of battery problems. If you have the budget, why not buy a new battery. :)

RIM BlackBerry... | Answered on Nov 24, 2017


It sounds like you're having problems with your processor. I would take it into a repair shop

RIM BlackBerry... | Answered on Nov 24, 2017

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