Robinair Logo

Robinair Recent Questions, Troubleshooting Help & Support

Do you work here? Claim your company

  • 79 Products
  • 418 Answers
  • 45K Views

sounds like you need to check the grommet between the motor and the pump. If this grommet connector breaks, the motor will come on but the pump will not work. Turn the unit upside down and look where the motor connects to the pump. Be aware if you can lose your oil while turning upside down unless you cap the port and exhaust. If this is it, go straight to the Robinair web site and you can order one for around $25.

Robinair... | Answered on Jul 12, 2019


Check oil drain solenoid for any debris or damage inside the solenoid flunger. Replace/rebuild as needed. Hope this will solve your problem. Don't forget to vote for my solution

Robinair Cool... | Answered on Jun 11, 2019


If you have less than 10lbs of refrigerant in the tank and you're changing modes, this can happen. If this is the case, Tech Support can help walk you through a reset process at 800.822.5561

Robinair Cool... | Answered on Jan 29, 2019


may be the cause is no power source, try to check voltage reading at your breaker, if the breaker itself has a power then the problem cause at your ROBINAIR, if you have guts to open the unit ?, try it and find which cause the trouble , thank you and GOD BLESS.

Robinair... | Answered on Oct 25, 2018


did you registrar and activate, call robinar, this still under warranty.

Robinair... | Answered on Aug 17, 2018


sorry only ROBINAIR can assist you

Robinair 34288... | Answered on Jul 08, 2018


you need professional assistance not from diyers

Robinair... | Answered on Jul 08, 2018

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top Robinair Experts

Mike

Level 3 Expert

4359 Answers

Gil Shultz

Level 3 Expert

3388 Answers

ray gallant
ray gallant

Level 3 Expert

63931 Answers

Are you a Robinair Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...