20 Most Recent 2005 Mercedes-Benz C-Class Questions & Answers


The gauge circuit runs through the pump fuse. Most likely the sending unit has failed inside the tank. :-(

2005... | Answered on May 05, 2019


Here is a video on how to do it.

https://youtu.be/1fE87pscWR4

2005... | Answered on Nov 02, 2018


Fiddley but doable open bonnet look where ligh clusters are there should be a plastic cover covering the rear of the lights there are 2 metal clips keeping this on remove back plate you can see the backs of the bulbs there will be a spring clip keeping which ever bulb you need to remove unclip this and the bulb will come out replace bulb the refit in reverse order hope this helps ivan

2005... | Answered on Sep 26, 2018


usually if the ecu says crank code then its a faulty sensor, can be both crank and cam. as if the crank sensor goes it will not start. cam it will start but not run correctly. low compression would mean eather water in oil, water in cylinders, or blow back on compression. but with all or any of these the engine would still start but run badly.

2005... | Answered on Feb 14, 2018


The stepper motor linkage for the left foot well flap is broken. I recommend having the linkage and the motor replaced at the same time. the repair is quite involved, so I recommend having a qualified MB tech do the repair.

2005... | Answered on Oct 24, 2017


Problem lies in either the fuel or ignition system. fuel pump working? Have spark to plugs? Crank sensor working?

2005... | Answered on Aug 21, 2015


did you remove the sensor for the exhaust gases this should reset its self after 50 miles or so if not may have to get it looked at properly

2005... | Answered on May 14, 2015


That is not normal. When is the last time you had the transmission serviced? Also Mercedes have a problem with the plug in the transmission. Every one we service gets the new plug.

2005... | Answered on Apr 05, 2015


Mitsibushi l200 my engine gave out so I put a older shogun engine in that i had runs great but this was one that didn't have a ecu and half the wires are not needed but my engine management light is on and can't get it to pass mot till it goes out they must come on and go out new mot rules

2005... | Answered on Mar 09, 2015


They are anywhere from 100 to 250 on Ebay but you need to know more information on what the model number is.

2005... | Answered on Feb 27, 2015


if you hear the starter engage but engine does not revolve with a known fully charged battery-you may have a leaking head gasket causing a hydro-locked engine.

2005... | Answered on Feb 21, 2015


If it fails to turn over then check on battery condition and on battery connections (do full beam headlights stay consistently bright for ten minutes). If Ok then check on wiring to and from starter motor and on condition of starter motor brushes. If turning over can you hear the fuel pump running; whirring sound when key at position prior to 'start'. If no fuel pump check on fuse for pump relay, check on relay, check on voltage at pump. If pump supplied with voltage but not running give it knock to see if you can get some kind of response from it. If completely dead replace pump and filter assembly.

2005... | Answered on Jan 23, 2015


Belt pulleys can make that noise. So can crank bearings, right before they sieze up.

2005... | Answered on Jan 16, 2015


You have to go back to the basics to find out what systems aren't working. Fuel/Fire/Air. Is it getting fuel, is it getting spark, how is the compression? Once you figure these things out then you will be heading on the right track.

2005... | Answered on Dec 03, 2014


Take it to a dealer. This isn't a user-replaceable unit.

2005... | Answered on Nov 29, 2014


This can be done by contact your service provider to connect his tool under steering with data connection to reset your entire setting

2005... | Answered on Nov 16, 2014


First check the fuse, check to see that you get a reading on at least one side. If you have nothing at the fuse, the wire from the battery to the Fuse-box is suspect. If you have a light this wire is not suspect. If you have both sides of the fuse powered, check the wires at the Fan itself for voltage~IF you have voltage the fan will need to be replaced. If you find that you don't have voltage at the FAN and the fuse is good, the wiring from the fuse to the fan is suspect. Thank You for using FixYa.com Come back if needed.

2005... | Answered on Sep 19, 2014

Not finding what you are looking for?
2005 Mercedes-Benz C-Class Logo

246 questions posted

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

C-Class Mercedes-Benz

  • C-Class Mercedes-Benz

Most Popular Question

2005 c230 mercedes benz fuel gauge not

  • Cars & Trucks
Loading...