Top 10 1999 Jeep Wrangler Questions & Answers

1999 Jeep Wrangler Logo

Question

  • 4,256 People Helped

NO BUS message on dash 99 Jeep Wrangler--No Start

have NO BUS on dash board where odometer is. Vehicle has no start, no spark, no fuel inj pulsation, all fuses good and will not communicate with my scan tool? 99 Jeep wrangler 4.0L

Posted by on

Answer

  • Most Helpful of 2 Answers

If the engine cranks and cranks but never starts ? It's almost always the CPS.



The most likely cause of it cranks and cranks but won't start up is the Crankshaft Position Sensor (CPS) located on the transmission bell housing. Often this part is also referred to as the CranKshaft Position Sensor (CKP) CPS/CKP failure is very common. The CPS/CKP can stop working with no warning or symptoms and the engine will not run or the engine may randomly stall for no apparent reason.

Crank Position Sensors can have intermittent “thermal failure”. This means that the CPS/CKP fails when engine gets hot, but works again (and will test as “good”) when it cools back down.

Begin with basic trouble shooting of the start and charge systems. Remove, clean, and firmly reconnect all the wires and cables to the battery, starter, and alternator. Look for corroded or damaged cables and replace as needed. Do the same for the grounding wires from the battery and engine to the Cherokee's frame/body. Jeeps do not tolerate low voltage or poor grounds and the ECM/ECU will behave oddly until you remedy this.



Symptoms –
- Starter cranks and cranks but engine won't start up and run.
- Fuel gauge and voltage gauges may not work or display properly.
- You sometimes will have No Bus on the odometer after 30-60 seconds.
- A failed CPS/CKP may or may not throw a CEL trouble code.
- No spark at the spark plugs.
- Fuel pump will run and prime for 3-5 seconds.

If the CPS/CKP is failed sometimes the OBDII code reader cannot make a connection to the computer or cannot read Check Engine Light/MIL codes because the CPS/CKP has failed.


Diagnostic steps to confirm the CPS is the cause of your no-start


You should be able to verify a bad cps, by unplugging it, and turning the ignition key to on. If the voltage gauge and/or the fuel gauge now displays correctly, replace the CPS.

Unplugging and reconnecting the CPS sensor where it connect to the main harness near the back of the intake manifold usually resets the ECU and if the jeep fires right up after doing this you can bet that the CPS is faulty and needs to be replaced.

Exchange the fuel pump relay and the ASD relay with one of the other similar ones in the PDC to eliminate the relays as the cause of the no-start Confirm that the fuel pump to runs for 3-5 seconds when you turn the ignition key to ON.

Eliminate the NSS as a cause of no start. Wiggle the shift lever at the same time you try to start. Put the transmission in Neutral and do the same. Do the reverse lights come on when the shifter is in Reverse?

Inspect the wires and wire connectors at the O2 sensors on the exhausts pipe. A short circuit from melted insulation or from broken O2 sensor wires can blow a fuse and the ECU/ECM will loose communication.


CPS Testing


Crankshaft Position Sensor Connector (CPS/CPK)


standard.jpg
.
standard.jpg

TESTING PROCEDURE 1991 – 2001 4.0L H.O. engines
1. Near the rear of intake manifold, disconnect sensor pigtail harness connector from main wiring harness.
2. Place an ohmmeter across terminals B and C (See Image). Ohmmeter should be set to 1K-to-1OK scale for this test.
3. The meter reading should be open (infinite resistance). Replace sensor if a low resistance is indicated.

TESTING PROCECURE for 1987 – 1990 4.0 L engines

Test # 1 - Get a volt/ohm meter and set it to read 0 - 500 ohms. Unplug the CPS and measure across the CPS connector's A & B leads. Your meter should show a CPS resistance of between 125 - 275 ohms. If the CPS is out of that range by much, replace it.

Test # 2 - You'll need a helper for this one. Set the volt/ohm meter to read 0 - 5 AC volts or the closest AC Volts scale your meter has to this range. Measure across the CPS leads for voltage generated as your helper cranks the engine. (The engine can't fire up without the CPS connected but watch for moving parts just the same!) The meter should show .5 - .8 VAC when cranking. (That's between 1/2 and 1 volt AC.) If it's below .5vac, replace it.


The 2000 and 2001 will have the CPS in the same location on the bell housing, but the wire connector may be on the passenger side, not as shown in the diagram below. Simply follow the wire from the sensor to the connector.

.
standard.jpg

Posted on Jun 17, 2010

Question

  • 3,224 People Helped

Check Engine Light - Code numbers P1486 & P0455

I purchased 1999 Jeep wrangler with 4.0 engine. The next day the check engine light came on. Took it in to have it looked at they said it was emissions. Replaced gas cap and other emission items. Light still keeps coming on. Show codes of:
P1486 Manufacturer Specific Code
P0455 Evaporative Emission Control System Leak Detected (gross leak).
Does anyone know what needs to be fixed by these codes and is this a specific problem with these models and years?
Sharon
Portland, OR

Posted by on

Answer

  • Most Helpful of 1 Answers

Both of those codes usually mean gas cap or "a vacuum hose, off, torn, or pinched"

Posted on Aug 14, 2008

Question

  • 2,619 People Helped

99 jeep wrangler 4.0 backfires and hesitates

my jeep backfires like crazy power goes in and out with constant idle changes in the first quarter mile, then with flooring the vehicle it goes away, leave the car for five minutes and it starts all over again. The jeep has been in and out of dealers no code comes up, just put a new exhaust maniforld on it same problem, anybody with any answers out there thank's

Posted by on

Answer

  • Most Helpful of 2 Answers

Fairly common problem. Typical scenario is start vehicle, runs fine for 15 to 30 seconds and begins to backfire when placed under load as customer tries to drive vehicle. Flooring usually makes the problem go away. Usually does not throw a code.

Fix is to replace the upstream 02 sensor.

Posted on Jan 10, 2009

Question

  • 2,529 People Helped

My check engine light came on in my 1999 Jeep

My check engine light came on in my 1999 Jeep Wrangler. Can I get the code without a reader?

Posted by on

Answer

  • Most Helpful of 2 Answers

do you have a digital ododmeter on this model

Posted on Aug 31, 2010

Question

  • 2,040 People Helped

1998 jeep wrangler fuel filter issue?

only happens within first 5-8 minutes of starting to drive. mainly in 2nd and third gear, while I'm driving the rpm's start to drop and the cars feels as if it is going to die. it starts to lurch as if I'm a horrible manual transmission driver, meanwhile I have not done anything but keep mu foot on the gas. To get it so I don't stall on the road, I have to drop gears or throw it in neutral, rev the engine and come back into gear. Once it starts, it happens for the next few minutes and then clears up. to me it feels as if there is a clog that the fuel cannot get by. My mechanics want to replace the whole pump. is that really necessary? thanks guys

Posted by on

Answer

  • Most Helpful of 3 Answers

Your fuel filter is part of the regulator located on top of the fuel pump. Though it is outside the tank, on many you need to drop the tank to get at it. Likely the shop wants to replace the entire thing because they do not want to take the tank down twice if changing the filter/regulator does not fix the problem. If you were my customer, I'd give you that option but make it clear that if the tank needed to be removed a second time you would need to pay for that. If the shop uses good quality parts and guarantee their work, there is nothing wrong with a complete exchange but I'd want to save the old pump as a possible "spare part" needing only a regulator to be returned to service. in an emergency situation.

Posted on Sep 08, 2009

Question

  • 2,030 People Helped

no BUS on odometer

I have a Jeep Wrangler Sahara 1999.It spent most its life in Vermont, now in Georgia. I parked it one day ,when I went to restart it the next morning it didn't start and the odometer read NO BUS. I have replaced PCM, and still nothing . When I used An OBD reader it coded unable to connect. I don't want to drop thousands into this in a shop. Any ideas?

Posted by on

Answer

  • Most Helpful of 1 Answers

I used to have the NoBUS show up on the odometer also, but always while driving. The immediate fix was a sharp rap on the top of the cluster with my fist. To fix it permanently, I removed the cluster,cleaned the contacts both cluster and harness with spray contact cleaner, then applied some dielectric grease to prevent any further corrosion.

HTH

Posted on Jul 01, 2008

Question

  • 1,976 People Helped

will not idle when cold

will not idle when cold

Posted by on

Answer

  • Most Helpful of 1 Answers

Its cold start issues:----
Go through the list of help links mentioned below:----

Click the link :----

Cold start problem and vehicle shudder around 2500 to 3500 rpms
http://repairhelpcenter.blogspot.com/2012/10/cold-start-problem-and-vehicle-shudder.html
----------
Low idle when cold out side?
http://repairhelpcenter.blogspot.com/2011/12/low-idle-when-cold-out-side.html
--------------
Ford explorer 4.0 will not idle when cold?
http://technoanswers.blogspot.in/2012/02/ford-explorer-40-will-not-idle-when.html
--------
Automatic transmission shift lever hard to move on cold mornings?
http://technoanswers.blogspot.com/2012/01/automatic-transmission-shift-lever-hard.html
----------
Car won't start when cold?
http://schematicsdiagram.blogspot.com/2011/12/car-wont-start-when-cold.html
-----------

It can be issue with IAC( idle air control valve) causing the problem.


There are many other possibilities causing these idle issues. Engine idles rough.

There are few help links with solutions to troubleshoot such idle issues.

I suggest you refer the link below and follow its troubleshooting details:------

Click the link below:-----

Ford Expedition IAC valve replacing

http://technoanswers.blogspot.com/2012/12/ford-expedition-iac-valve-replacing.html

Bad miss at idle?

http://technoanswers.blogspot.com/2012/01/bad-miss-at-idle.html

-----------

Stumbling and stalling at idle after engine rebuild?

http://schematicsdiagram.blogspot.in/2012/03/stumbling-and-stalling-at-idle-after.html

------------

1999 Ford F-150 Idles rough and quits when gas pedal is pressed less?

http://technoanswers.blogspot.in/2012/01/1999-ford-f-150-idles-rough-and-quits.html

---------

Engine stumbles coming off idle when warm?

http://repairhelpcenter.blogspot.com/2012/01/engine-stumbles-coming-off-idle-when.html

------------------

Erratic idle on car?

http://schematicsdiagram.blogspot.com/2011/12/erratic-idle-on-car.html

-----------


Cold start problem and vehicle shudder around 2500 to 3500 rpms

http://repairhelpcenter.blogspot.com/2012/10/cold-start-problem-and-vehicle-shudder.html

----------

Low idle when cold out side?

http://repairhelpcenter.blogspot.com/2011/12/low-idle-when-cold-out-side.html

-----------

GMC Sonoma Stalls and idles low

http://technoanswers.blogspot.com/2012/10/gmc-sonoma-stalls-and-idles-low.html

--------


GMC Idle Air Control (IAC) Valve Replacing?

http://schematicsdiagram.blogspot.com/2011/12/gmc-idle-air-control-iac-valve.html

-------------

1996 Camry intermittent engine failure while idle?

http://repairhelpcenter.blogspot.com/2011/10/1996-camry-intermittent-engine-failure.html

------------

Engine quits at idle?

http://repairhelpcenter.blogspot.com/2011/10/engine-quits-at-idle.html

-----------

Car overheats and Air blows hot at idle?

http://howtobyme.blogspot.com/2011/11/car-overheats-and-air-blows-hot-at-idle.html

---------

High Idle Problem

http://repairhelpcenter.blogspot.com/2012/10/high-idle-problem.html

-------

While stop engine idles like cylinder missing?

http://schematicsdiagram.blogspot.com/2012/01/while-stop-engine-idles-like-cylinder.html

---------

Idle flair is noticed on car? Rough idle? car will not idle? Erratic idle speed?

http://technoanswers.blogspot.in/2012/02/idle-flair-is-noticed-on-car-rough-idle.html

--------

High rpm in neutral? Inconsistant high RPM in neutral?

http://technoanswers.blogspot.in/2012/02/high-rpm-in-neutral-inconsistant-high.html

-------

Vehicle stumbling at idle and shows code 54?

http://schematicsdiagram.blogspot.in/2012/03/vehicle-stumbling-at-idle-and-shows.html

----------

Rough idle, staling and Erratic shifting?

http://technoanswers.blogspot.in/2012/03/rough-idlestaling-and-erratic-shifting.html

-----------

While stop engine idles like cylinder missing?

http://schematicsdiagram.blogspot.com/2012/01/while-stop-engine-idles-like-cylinder.html

---------

These details will help.

Thanks.

Posted on Dec 14, 2012

Question

  • 1,831 People Helped

Jeep TJ Heater Fan Repair

I have 1999 Jeep TJ and recently the heater fan, on the climate controls, stopped working. The fan has 4 on settings (speeds) and then the off position. I initially lost the third speed, then the second, and now all of the speeds don't work. How do I fix this?

Posted by on

Answer

  • Most Helpful of 2 Answers

blower motor resister has burnt out also check wiring going to your blower motor resistor these must have a good tight connection or they will burn if any sighns of being hot change the complete wiring pig tail to your blower resistor

Posted on Sep 19, 2009

Question

  • 1,608 People Helped

how much transmission fluid is in a 1999 jeep

how much transmission fluid is in a 1999 jeep wrangler

Posted by on

Answer

  • Most Helpful of 1 Answers

Automatic Transmission, 32RH Initial Fill..........4.1 quarts
Automatic Transmission, 30RH Initial Fill..........4.1 quarts
Automatic Transmission, Total Fill
3 speed 32RH..........8.6 quarts
3 speed 30RH..........7 quarts
Manual Transmission, AX-5 2WD..........7.4 pints
Manual Transmission, AX-15 2WD..........6.8 pints
Manual Transmission, AX-15 4WD..........6.8 pints

Posted on Feb 14, 2011

Question

  • 1,569 People Helped

1999 jeep wrangler dash gauges not working

1999 jeep wrangler dash gauges not working

Posted by on

Answer

  • Most Helpful of 2 Answers

likely connection behind dash. Easy fix - remove dash, twist cannectors behind dash and put back together. All gauges will e working again. 10-15 mins tops

Posted on Jun 19, 2011

640 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

1995 Jeep Wrangler
1995 Jeep Wrangler

625 Questions

1997 Jeep Wrangler
1997 Jeep Wrangler

538 Questions

1998 Jeep Wrangler
1998 Jeep Wrangler

522 Questions

1992 Jeep Wrangler
1992 Jeep Wrangler

334 Questions

2000 Jeep Wrangler
2000 Jeep Wrangler

-143 Questions

Top Jeep Experts

Marvin
Marvin

Level 3 Expert

85206 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

1999 Jeep Wrangler Wrangler

  • 1999 Jeep Wrangler Wrangler

Most Popular Question

1999 jeep wrangler 2 4l 5spd circle w

  • Cars & Trucks
Loading...