Question about 1995 Geo Metro

1 Answer

Motor runs at 4000 rmp when started

Replaced tps part..same prob...choke assy is open alittle bit also...should be closed?

Posted by on

  • 7 more comments 
  • Dean Brandl
    Dean Brandl Jan 30, 2014

    1.3 liter,USA didnt know the tps had to be calibrated,how is that done? diagnostic code showed tps problem only.Replaced the part..still does the same,starts fine,but goes to 4ooo right away.Choke is open also about 1/8 inch..i tried to manually close it..it wont close any futher.

  • Dean Brandl
    Dean Brandl Jan 30, 2014

    havent had new part checked yet tp see if its bad.

  • Dean Brandl
    Dean Brandl Jan 30, 2014

    regristration says 96yr. has throttle body assy.

  • _-__-___-_
    _-__-___-_ Jan 31, 2014

    what country, what VIN? the VIN tells me engine, and year. Diagnosis depends on that. I cant see under hood so.....????? here is an example. JG1MR3369TK201234 (the T means 1996) THE DOOR JAM DATE IS BUILD DAte, which could be July1, 1995 and means nada. the 8th digit is the ENGINE code.. 3-cyl = 6, 4-cyl (1.3) = 9.. i think the code 9 engine began , in 1998. if your car IS a VIN coded 1996 and is in the USA< It will be OBD2 compliant AND as such,any scan tool will scan this Engines PCM/ECU. is it USA car? sold there?

  • _-__-___-_
    _-__-___-_ Jan 31, 2014

    Does the CEL lamp glow key on. Y/n

  • _-__-___-_
    _-__-___-_ Jan 31, 2014

    Does it go out , running engine (dash warning lamp CEL):?

  • _-__-___-_
    _-__-___-_ Jan 31, 2014

    does the idle race Hot and cold engine, (or both ) at 4000 RPM?

  • _-__-___-_
    _-__-___-_ Jan 31, 2014

    You 3cyl , engine IS , TBI engine, throttle body engine ,with a MAP sensor that runs the show. and all these engine RACE at idle if there are any vacuum air leaks, finding where the leak comes from takes very hard work. a simple hose cracked to bad IAC. or throttle body leak.

  • _-__-___-_
    _-__-___-_ Jan 31, 2014

    did you calibrate the TPS, if not , it can race. The TPS tells the ECU when you are at idle if not, the ECU cancels idle controls.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Geo Master
  • 20,706 Answers

1995 Geo Metro. COLD start or HOT started or BOTH?
Does it ever idle down to 800 HOT? (engine temp)>?

Aka:
Geo Metro (later re-branded the Chevrolet Metro), Pontiac Firefly, and Suzuki Swift
which engine, what country???
I will post for USA only !!!!
Auto or stick tranny???
the USA 1995 was the last car to use TBI injection (throttle body)
the LSI option, then had a 4 cylinder. in 1.3Liters.
and works totally differ. than any 1.0L
answsering for 1.0L

Have you inserted the Diagnostic jumper wire and looked at the
FLASH codes yet?
choke? on 95? what country is this, ours are not carbs. in 1995.
so post country. ours are all EFI in USA.
3 cylinder? 1 liter? or which engine/?
on any USA Metro, 1L , when first started, it has 2 valves. to control IDLE, (cold , is iAC) hot is ISC, The cold start valve opens farther the colder it is (how cold was it). but usually is limited to about 2000 rpm
max.
this engine, TBI, uses a MAP to control fuel mixtures, and
any air leaks (aka; vacuum leaks) what so ever, will cause too fast idle.
so on MAP cars, you get to find out what is leaking AIR.
1995 has the new better , idle control speed motor, (ISC)
this can be stuck open.
that new TPS, did you do the calibration correctly?
it must set right. or idle will never be controlled.
finding the cause, takes hard work, and hands on testing
A/C fast idle broken
A/T transmission fast idle, device, broken.
Air leaks (add huge list of possibles and cracked hoses here)
Throttle stuck
ISC or IAC bad.
very hands on to find this, done many.
TPS on indexed corrrectly or not calibrated.

Posted on Jan 29, 2014

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a problem in a 1995 lexus es300 i start the car and it feels like a flooded start once the engine is on, i step on the gas and it floods only when accelerating, if i accelerate slowly it will go up...


Most cars have a rev limiter built in and will not let the engine goe past 4000 rpm's you may want to change out the spark plugs as often if it has flooded just once the plugs do foul out

Aug 15, 2014 | Cars & Trucks

1 Answer

I have a Kia Sedona van 2002 . I stoped to fill it up with gas but i left it running after i filled it up full the van started acting funny and died. I started it back up ran alright then the rpms go up...


Could be a sensor , but without testing , this would be a guess ! Have seen TPS - throttle position sensors on chysler products do this , Mass air flow sensors on GM vehicles , plus bad IAC - idle air control motor . Don't think you would like to replace all these parts , your best bet , take it to a qualified repair shop . Have it tested !

Mar 27, 2017 | 2002 Kia Sedona

2 Answers

When the engine starts it goes to 2000 RPM immediately


first thing clean throttle body,good clean.Maybe TPS sensor or IAM.

Apr 01, 2013 | 1999 Jeep Wrangler

1 Answer

My car would start this morning but then kept shutting off. I replaced the throttle positioning sensor now it stays running but at a real high idle?


Possibly the wrong TPS? Also check for carbon build up in your throttle plate; if there is you may clean it with choke cleaner - be careful not to get the choke cleaner on your idle air control motor as it will cause it to seize.

Your IAC motor may be faulty. Remove it from the throttle body and push down steadily with your thumb; it should move without applying too much pressure; if not - replace. You will need to drive the car after replacing an IAC motor so that your computer can "learn" the idle position.

Sep 04, 2012 | 2004 Chevrolet Chevrolet Impala

2 Answers

I have a 1986 4wd p.u efi that that i got from relatives who put an engine in thier selfs the motor runs alittle rough ive changed the fuel filter checked plug wires distribter cap rotor put some fuel...


it might be a vacuum problem i have notice that the older Toyota's had i have dealt with allot of them and they have allot of vac lines to i would start with those first though

i hope this helps !

Feb 27, 2011 | 1986 Toyota Pickup 4WD

2 Answers

MY TRUCK HAS A 318 ENGINE IN IT.AFTER IT IS STARTED IT WILL SPIT AND SPUTTER FOR ALITTLE BIT THE IT WILL IDLE FINE AFTER IT RUNS FOR 5-10 MINUTES OR SO.IF I DONT LET IT WARM UP IT WILL SPIT AND SPUTTER AND...


Sounds to me like your choke is malfunctioning. Take the cover off of your carb when cold and see if the choke (top buttefly valve) is closed. It should be when cold. (you do not say what year truck you have so I am guessing as to the answer)

Nov 29, 2010 | Dodge Ram 150 Cars & Trucks

1 Answer

Revs upto 4000 rpm in idle and while driving too ! all by itslef.


mcdevito75 here, Sounds like the idle speed motor or the idle speed sensor is no good. Your local shop can check this out for you.

Jun 17, 2010 | Hyundai Motor 2002 Sonata

1 Answer

Justs shut down at stop sign also in morning actully all day. starts up then will shut down for no reason some days no problem at all.all so traveling down freeway it starts chugging like its running out...


you need to have your throttle position sensor checked. tps its starts goi9n bad and get erratic readings to the computer. i just experienced some what the same problem, come to stop sign, let off gas pedal it dies. i set up the idle a lil bit and solved the prob and then had tps checked. replaced it and solved the prob. not 100% that that is the prob but that is what i experienced.

Feb 11, 2010 | 1995 Ford F250

Not finding what you are looking for?
1995 Geo Metro Logo

287 people viewed this question

Ask a Question

Usually answered in minutes!

Top Geo Experts

Marvin
Marvin

Level 3 Expert

85216 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Geo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...