Question about 1993 Geo Metro

1 Answer

My 93 Geo Metro 1 liter 5 speed runs fine but ifvu

My 93 Geo Metro 1 liter 5 speed runs fine but ifvu drive it a lot it fluids out and the only way to start it back is unplug the injector and spin the motor then plug it up and crank it. wjat causes this

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Geo Master
  • 20,706 Answers

6th post wins, with Injector.
the injector can fail for these reasons.
the problem in car lingo, is FLOODING.
and after doing all that did it run? (my other shoe drops)!

1: the 0-rings bad, on side.
2: the injector is bad, it leaks.
3: the ECU injector drive line is failing. (bad ECU)
4: loss of spark always ends in flooding.
5: ECT sensor bad, sending water temp reading to -40C Siberian.
did you get the FLASH codes from the CEL lamp yet, with the
diagnostic jumper , inserted?
6: bad need of tune up, air filter clogged, spark plugs long ago, dead.
do a tuneup every 10 years, or 60k miles and win..
7: Cam belt slipped, low compression for any reasons. again, the 60k mile tune up wins.

when you crank the engine over, with the throttle at wide open throttle
this ACT, cuts all injections. cranking, this covered in the operators
manual, for UN-Flooding all gas engines. and all EFI engines.
and all Suzuki's' (or Geos)

on old dogs like this, i do compression first.
saving a fortune in parts , time and labor, if bad.
do it WOT, wide open throttle.

cheers !

Posted on Sep 24, 2014

Ad

2 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
alicantecoli

Colin Stickland

  • 22485 Answers

SOURCE: no fire(spark) on my 1.0 liter 95 geo metro, coil

ignition module is most likely ,but it could be the crank sensor unless you have a distributor as some older opel corsas had the pick up sensor inside the distributor

Posted on Dec 03, 2010

Testimonial: "thank you! ive been wearin out my poor brain, and you just confirmed what i had suspected lol i was misled by others lol! God Bless"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1993 Geo Metro 1 liter 4 cylinder fluids and


6 posts, but adds , Gets
what does that mean?
leaks fuel
or engine runs too rich.
what?

Sep 24, 2014 | 1993 Geo Metro

1 Answer

I have a 1993 Geo Metro 3 cylinder 1 liter 5


6 posts this one, worse that all.
the word out , what does that mean,?

Sep 24, 2014 | 1993 Geo Metro

1 Answer

My 93 Geo Metro 3 cylinder 1 liter 5 speed fluids


6 posts. same out word.
what fluid, gasoline, water, oil , what? from WHERE?

Sep 24, 2014 | 1993 Geo Metro

1 Answer

I have a 93 Geo Metro 1 liter 5 speed. it runs


6 posts but not one explaines this
but it fluids out.
what fluid and out of what.? name both.

Sep 23, 2014 | 1993 Geo Metro

1 Answer

Why will my 1995 Geo Metro not start?


You have a pick-up coil in the distributor that tells the computer when to fire the injectors, I would guess this might be your problem, you are getting fuel to the injectors, but not into the engine.

Aug 09, 2014 | 1995 Geo Metro

1 Answer

Auto trans will shift some times and manual only


It may be just the vehicle speed sensor. Does the speedometer work OK? The vehicle speed sensor tells the computer how to control the shifting and it also sends a signal to the speedometer. Is the trany full of fluid, is it fairly clean? It should be red. Most vehicles, you check the fluid with the engine idling, in park.

Dec 12, 2009 | 1992 Geo Metro

1 Answer

I HAVE A 93 GEO METRO.AUTOMATIO I REPLACES ENGINE WITH 92 5 SPEED. MOTOR IDLES WELL. WHEN I TRY TO DRIVE IT NO THROTTLE RESPONSE.NO CHECK ENG. LIGHT. IS IT POSS. THAT MY T.P.S. IS BAD. OR MY INJECTOR....


You need to check the wiring diagram, the control modules are numbered with letter following to indicate if they are for an auto or manual transmission. Sounds like you have a circuit open that the computer needs to see, but I'm guessing that you need to change the module. Good luck,
Mike

Sep 29, 2009 | 1993 Geo Metro

3 Answers

Someone put Dexron 2 automatic transmission fluid in the manual transmission of my 1992 geo metro. If I put the GL-5 75w in there, will it cause a problem?


I would first drain the transmission fluid out completely first. Then go ahead and add the correct fluid ( the GL-5 75w) sounds like the correct fluid you should use.

Jun 28, 2009 | 1992 Geo Metro

1 Answer

1997 Geo Metro


probably a radiator problem go see a mecano

Jul 19, 2008 | 1997 Geo Metro

Not finding what you are looking for?
1993 Geo Metro Logo

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Geo Experts

Marvin
Marvin

Level 3 Expert

85222 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Geo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...