Tylo DELUXE 7 Sauna Heater 7 kW - Page 8 - Answered Questions & Fixed issues


go online and search for single pole single throw toggle switch.
Since the motor does not have a switch from factory you must furnish power cord. See if a wall light switch will fit your box.
Look om switch for model number and search that model number

Pool & Spa | Answered on Jun 08, 2019 | 53 views


If the breakers are double ganged yes. If you are not experiences electrically and are trained and licensed do not attempt any repairs. Trip to ER will more that pay for a service call.

Pool & Spa | Answered on Jun 07, 2019 | 57 views


turn it off and see if it is still beeping after you turn it back on tomorrow?

What is it? A hot tub or a spa?


Swimming pool??

Pool & Spa | Answered on Jun 07, 2019 | 57 views


hls is high limits Check flame sensor and burner tube below it if ok possible calcium build up in heat exchange or low gas pressure

Pool & Spa | Answered on Jun 06, 2019 | 67 views


Remove screws on multiport and lift off top then shop vac sand out

Pool & Spa | Answered on Jun 06, 2019 | 74 views


check fuse for heater or temp sensor also check recirculation pump

Pool & Spa | Answered on Jun 06, 2019 | 58 views


Just a wild guess, since I'm not familiar with the product: The pump motor may be overheating and is being saved by a thermal cutout. Check the ventilation around the motor and make sure vents are not blocked. If the motor is loaded with dust, clean it off. Check the pump inlet screen to make sure it isn't clogged; this would make the pump work much harder. Finally, if you have access to the shaft between the pump and motor, remove power from the motor and try turning the shaft by hand. Excessive friction or side play in the shaft indicates bearing problems.

Pool & Spa | Answered on Jun 04, 2019 | 64 views


drag ir behind the boat as you are coming back to dockage .

Pool & Spa | Answered on Jun 04, 2019 | 55 views


No will ruin pump needs filter to force water into it

Pool & Spa | Answered on Jun 03, 2019 | 57 views


There could be many answers to that question. It could be doing the right thing and turn it off if it reaches its target temperature or a faulty sensor or a faulty PCB board. Good luck

Pool & Spa | Answered on Jun 02, 2019 | 59 views


air in pump ---clogging filter ---pump failing ---debris in line or pump --motor failing

Pool & Spa | Answered on Jun 01, 2019 | 59 views


there are also battery operated vacuums which collect the debris in a onboard receptacle. they are not pricey either. you just need to match the pools volume to the related vacuum size

Pool & Spa | Answered on May 29, 2019 | 59 views


see if drain on bottom if not use a simer pump

Pool & Spa | Answered on May 29, 2019 | 489 views


Bad air pump if voltage to pump if no voltage check switch or relay

Pool & Spa | Answered on May 29, 2019 | 54 views


make sure chlorinator is at least on 5% or more then it will show up

Pool & Spa | Answered on May 29, 2019 | 49 views


if leaking around o ring means not ok with seal either damaged housing or seal failure

Pool & Spa | Answered on May 29, 2019 | 42 views

Not finding what you are looking for?
Tylo DELUXE 7  Sauna Heater 7 kW Logo

Popular Tags

0 questions posted

Ask a Question

Usually answered in minutes!

Top Tylo Pool & Spa Experts

Bill Jordan

Level 2 Expert

375 Answers

john h

Level 3 Expert

22486 Answers

David Spradling
David Spradling

Level 3 Expert

10391 Answers

Are you a Tylo Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...