20 Most Recent Denon AVR-1513 Questions & Answers


Short circuited component/s inside the circuit board.

Denon AVR-1513 | Answered on Oct 25, 2015


Power supply section circuit problem. Check all the voltages and filter capacitors at this section. Contact any service technician. If you wish to get some details; check the site linked here. Pull up older posts. Surf the site with patience. http://electronicshelponline.blogspot.com/

Denon AVR-1513 | Answered on Jun 02, 2015


If you wish to get some details; check the site linked here. Pull up older posts. Surf the site with patience. http://electronicshelponline.blogspot.com/

Denon AVR-1513 | Answered on Aug 10, 2014


you have to goto setting and set the speaker to tv if you have a newer tv

Denon AVR-1513 | Answered on Mar 28, 2014


How many times this power/standby light blinks? It is fault indication, and are fault codes. If you wish to get some details about these codes, try this link. http://electronicshelponline.blogspot.com

Denon AVR-1513 | Answered on Dec 23, 2013


set the speaker as default, whichever you are testing, it will start working, just right click and select.

Denon AVR-1513 | Answered on Dec 15, 2013


This could be due to the systems overload protection kicking in, which under normal circumstances shouldn't happen, I suggest moving the speakers next to the amplifier and if possible use anew piece of wire to test the speakers start with one and test each individually. I think you possibly have a small short in one of the wires. Or one speaker is damaged. Measure the resistance between each speaker wire pairs. The speaker will probably be either 4 or 8 ohms check that this is the case. Read the speaker labels for clues. Were they the original speakers supplied? by the same manufacturer?

Denon AVR-1513 | Answered on Dec 09, 2013


make sure the wattage of the amplifier has the same amount or more wattage to the subwoofer otherwise it will not be able to produce sound because of power complications

Denon AVR-1513 | Answered on Dec 07, 2013


Check and replace its main system control memory IC.

Denon AVR-1513 | Answered on Aug 23, 2013


Check its speaker connections. Check the speaker using a dry cell. If it is found OK, check the sound settings. If you wish to get more details, check this link.

Denon AVR-1513 | Answered on Mar 22, 2013


Appears to be a software problem. Unfortunately, some blu-ray players contain software that expires, requiring you to repurchase newer, more expensive software from the manufacturer in order to continue to play blu-ray discs. Check your software for the player. No freeware blu-ray software out there.

Denon Televison... | Answered on Nov 13, 2019

Not finding what you are looking for?
Denon AVR-1513 Logo

Popular Tags

24 questions posted

Ask a Question

Usually answered in minutes!

Top Denon Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76173 Answers

Ekse

Level 3 Expert

13434 Answers

 Grubhead
Grubhead

Level 3 Expert

5699 Answers

Are you a Denon Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Denon Televison & Video

  • Denon Televison & Video

Most Popular Question

unit not powering

  • Televison & Video
Loading...