20 Most Recent KitchenAid Artisan Series Tilt-Head Stand Mixer - Page 6 Questions & Answers


It will run fine without the filter if you choose to bypass it. If your 110 volt filter is not up to handling the 230 volts the filter will only go bang and smoke it won't harm anything else. I have looked at the capacitors on a 230 volt filter and they are 250v - 275v so just read what's on your 110v filter. What you need to change is the armature, the fields and the small phase board under the back cover..

KitchenAid Food... | Answered on Jan 03, 2018


Could be a defective power switch or interlock

KitchenAid Food... | Answered on Dec 17, 2017


Check that the motor brushes are not worn out. Under the black screw caps one each side of the motor. Note that the brushes have one corner shaved off, they only fit properly one way.
Remove the back cover (one screw at the top) and check for a broken or fallen off wire. If that doesn't solve it then you are going to need a multi meter and start testing for a break in the circuit.

KitchenAid Food... | Answered on Nov 30, 2017


Check that the motor brushes are not worn out. Under the black screw caps one each side of the motor. Note that the brushes have one corner shaved off, they only fit properly one way.
Remove the back cover (one screw at the top) and check for a broken or fallen off wire. If that doesn't solve it then you are going to need a multi meter and start testing for a break in the circuit.

KitchenAid Food... | Answered on Nov 30, 2017


Fashion another knob out of something similar looking and bond it onto the shaft with epoxy resin. Think of another appliance that may have a black knob on it....a toaster knob maybe. A knob off an old fashioned heater control in a car.

KitchenAid Food... | Answered on Nov 17, 2017


Maureen it's probably not a good idea to put to put all that personal information here on a very public forum. Contact Kitchen Aid and ask them for contact information for the longest established authorised repairer in your locality.

KitchenAid Food... | Answered on Nov 08, 2017


Sadly we know of none since mixers are not a high cost item fixing one is more costly than a replacement

KitchenAid Food... | Answered on Oct 22, 2017


Your description is very incomplete. Does it not start turning until the lever is at position 8 or does it run at high speed from the moment it starts at position 1?
If it's not starting until position 8 then the problem is probably mechanical and will require some parts to be replaced or adjusted.
If it starts on high speed at position 1 then it's likely you need to replace the phase board under the back cover at the top.
Whatever you decide to do check the carbon brushes first as worn out brushes can sometimes create funny speed problems.

KitchenAid Food... | Answered on Oct 19, 2017


They made more than one model, pity we don't know what yours is.

KitchenAid Food... | Answered on Oct 11, 2017


This is most likely has to do with either or both the control plate and control link. If the spring which goes from the control link to the control plate is not connected, the power to the motor will not turn on properly. This is most likely the source of your problem.

Take a look at the Service Manual which covers your mixer (even though it may not specifically reference your model):

http://www.kitchenaidparts.eu/documents/pdf/service-manual/classic-svc-manual-new-email-version.pdf

KitchenAid Food... | Answered on Oct 02, 2017


check thru kitchen aide website

KitchenAid Food... | Answered on Sep 30, 2017


Try Googling (KitchenAid)(ksm90)(manual) without parens.

KitchenAid Food... | Answered on Sep 14, 2017


Check the carbon brushes, look inside the hole, it is keyed, the brushes only go in properly one way. Match the missing corner on the brush to the blocker inside the brush holder.

KitchenAid Food... | Answered on Sep 11, 2017


The Service Manual for this model (yes, it covers the 5 qt. model as well) can be found at: http://ep.yimg.com/ty/cdn/mendingshed/kitchenaid6qtservicemanual.pdf

KitchenAid Food... | Answered on Aug 29, 2017


Make sure that the carbon brushes are not worn out or if you have already had them out make sure that they have been put back in properly. There is one corner ground off each brush that needs to line up with a blocking corner in the brush holder. Then get your multi meter out and check the unplugged main cable for continuity to the speed control panel. Then check each half of the field assembly for continuity from the speed control plate to a brush holder. Check you have no broken wires to the speed control plate. Check that the switch on the speed control plate is functioning. If all that tests OK I'd replace the phase board, it's worth not much and worth a shot.

KitchenAid Food... | Answered on Jul 31, 2017

Not finding what you are looking for?
KitchenAid Artisan Series Tilt-Head Stand Mixer Logo

41 questions posted

Ask a Question

Usually answered in minutes!

Top KitchenAid Food Mixers Experts

Appliance engineer

Level 2 Expert

162 Answers

CJ C
CJ C

Level 2 Expert

66 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Are you a KitchenAid Food Mixer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

KitchenAid Food Mixers

  • KitchenAid Food Mixers

Most Popular Question

hinge pin came out from head mixer

  • Food Mixers
Loading...