Question about Alphasonik PMA800DA Car Audio Amplifier

Open Question

I got my subs hooked up but the amp is not working for my alphasonik

Its not turning on at all

Posted by Anonymous on

Ad

3 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
ronaldo_ross

Ronado Panaligan

  • 1056 Answers

SOURCE: amp cutting out when bass hits

make sure that all the connections to the power supply are tight. The protection circuit is doing this so that your amp do not burn up. The size of your amp also demand heavy wiring. Make sure you used the recommended size. Also you need to make sure that the battery and the alternator can keep up with its large demand. You may need an extra battery too. I know a single battery can deliver a lot of current, but a powerfull amp demands the current really fast, when the bass hits. You can use a large damping capacitor, they are extremely big, or you can add another battery. All these will also give your amp more thump, and make it operate at full efficiency. meaning even louder! If these do not solve the cutting out issue, you may have to turn down the gain down slightly. Every type of music do not deliver same amount of bass, hip hop music, and rap would require you to trim down the gain some. Bass is delivered at its best in moderation, too much and you end up with a rattle rather than solid bass. I have a 4,000 watts amp at home, I don't use it in my car. I got it rigged up as a house stereo. I bought it for a 100 bucks broken, and fixed it. I have worked with hundreds of car amps a before in a electronic shops, I also design small amps once in a while. I myself love those loud gadgets. Well hope it has been helfull. Goodluck.

Posted on Jul 01, 2009

Ad

Anonymous

  • 113 Answers

SOURCE: alphasonik amp is getting power but no power to subs

either your rca inputs are bad or your mosfets are bad

Posted on Jul 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Alphasonik 12 inch series 800 is not working. I'm not sure what's wrong with it


Have you tried to hook up another sub (spk) to the amp? Or just wire it to a stereo to see if it works? single voice coil or dual?

Aug 15, 2016 | Alphasonik Car Audio & Video

1 Answer

How can i get my speakers fixed


It may not be the subs, but the amp could have caused the subs blowing/freezing up. If an amp is clipped it will send to much voltage to the subs, thus blowing the subs. Clipping the amp is when someone sets the gains on the amp to higher than the sub can handle. Find this out before you buy new subs. If not, you may have blown subs again.

Sep 28, 2012 | Alphasonik PSW112C Alpha 100 Series 12"...

1 Answer

Trying to 1ohm my sub for a 2 channel brideable amp


you can only do that if your sub has a switch on it otherwise just hook it up and pound it

Sep 08, 2011 | Alphasonik Mayhem PSW912 Car Subwoofer

1 Answer

I would like to know if I need a special plug to bridge the amp and were can I buy the owner manual


I just got an alphasonik pma800da today, it came with the cord you are talking about. Looks like a phone cord, its to hook up 2 of these amps together. I also have the book to the amp

Dec 26, 2010 | Alphasonik PMA800DA Car Audio Amplifier

1 Answer

Which speker box should i use for alphasonik


If it is an open air sub ( hole with mesh in the center of the magnet) no ports are required, and the box should be sealed on the inside with silicone sealant. If it is a closed air sub ( no hole in the magnet) you need a 50mm port about 120mm long Box size will be 13 inches x 13 inches x 13 inches

Mar 15, 2010 | Alphasonik Mayhem PSW912 Car Subwoofer

1 Answer

When power is applied, one sub hits fine and the other looks like its being pushed out really hard, continuously.


sounds like the amp is sending dc voltage to the sub. you probably have bad output transistors in the amp.

Mar 09, 2010 | Alphasonik PSW410 Car Subwoofer

1 Answer

How do i hook up the voice coils up to 2ohm stable?


depends on the impedance of the coils on your subs and if they are single coils or dual coils. If you are trying to achieve a 2 ohm load then a pair of 4 ohm coils in parallel will do the job.If you have dual 4 ohm coils on your subs then you will have to use only one coil from each sub which will still give you the 2 ohm load that you seek but it will affect the power handling of the subs by half as you are only using half of the coils.

Jan 13, 2010 | Alphasonik PSW110 Car Subwoofer

2 Answers

I have 2 positives and 2 negatives on back of my alphasonik sub, do i connect amp to one side or both sides?


Hello gaz69,

Your PSW815 has 2 ohm dual voice coils allowing you to better match the impedance to your amp. Each voice coil is 2 ohms. If you wire them in parallel (both +'s together and both -'s together and then to the amp terminals), the sub presents a 1 ohm load which is too low for most amps. Wiring the voice coils in series (one + to the other - and the remaining + and - to the amp terminals) results in a 4 ohm load.

This link shows the wiring diagram for both options. If you know for sure that your amp is 1 ohm stable, use Wiring Option #1. If the amp is not 1 ohm stable, use Wiring Option #2.

Hope this helps.

Aug 09, 2009 | Alphasonik PSW815 Car Subwoofer

1 Answer

Alphasonik amp is getting power but no power to subs


either your rca inputs are bad or your mosfets are bad

Jul 05, 2009 | Alphasonik PMA1000D Car Audio Amplifier

2 Answers

Amp cutting out when bass hits


With an amp like that you can not pull enough power from you cars battery alone. That is why when it hits hard it drains the amps from your battery and you amplifier cuts out. The light on the amplifier most likely dims when the bass hits. You need to get a capacitor. They are easy to hook up on the main power wire. You can get one from http://phatcaraudio.com/capacitors.html or get a used one off ebay.com. Good luck

Jul 01, 2009 | Alphasonik PMA1000D Car Audio Amplifier

Not finding what you are looking for?
Alphasonik PMA800DA Car Audio Amplifier Logo

Related Topics:

24 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alphasonik Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

The Knight
The Knight

Level 3 Expert

76171 Answers

Are you an Alphasonik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...