Question about Asrock K7S41GX Motherboard

2 Answers

No pwer hi i got a asrock k7s41gx motherboard but when i put it in my case iv got no power and wont turn on i no its not me power supply coz im using it now

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 113 Answers

Check conections, did you isolated bolts while you ware inserting mother board? check condensators on mother board if there are some leeks... if this is the case ,,, buy a new mother board? is mother board new?

Posted on May 02, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

This is usually caused by 4 things.
1. defective motherboard
2. defective power supply
3. lose/faulty power cable connections
4. power/reset button pinouts incorrectly seated or in wrong slots.

You have already verified your power supply works so go with the other 3.

Check all your power connections are seated properly.
Check that your power button pinouts are seated in the right pins. Check the manual to see the correct placement. The manual could even have a typo (who knows). If you are sure of the placement i would call ASRock support and ask for guidance or request an RMA if it is under warranty. If this board was installed and previously working i would assume it is faulty.

manual
http://www.asrock.com/mb/manual.asp?Model=K7S41GX&s=462

i guess it could be your case as well. How many pins are coming off your power button?

Posted on May 02, 2009

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Is there driver for mothetherboard asrock ata 133 for win7


HERE IS THE SITE FOR DRIVERS AND BIOS UPDATE FOR THE ASROCK K7S41GX (http://www.asrock.com.tw/mb/download.asp?Model=K7S41GX&o=All)

Nov 25, 2009 | Asrock K7S41GX Motherboard

1 Answer

Pci video card


If you have internal graphics, you need to enter the BIOS and change the vide setting to PCI-E, AGP,Etc.., save and exit the BioS, power off PC, then install video card, make sure all needed power connectors on vide caard are plugged in (some nes cards require a plug from the power supply to be used as well as the power provided from the PCI-E slot)
gomez73

Mar 26, 2009 | Asrock K7S41GX Motherboard

1 Answer

Auto power when the power socket is switched on


Try resetting all the hardwares of your motherboard? especially the processor and the copper side which is color gold, clean it with an eraser

Jan 14, 2009 | Asrock 845GV (P4I45GV) Motherboard

1 Answer

Asrock K7S41GX Problem with video card.


Bigger power supply 450 to 500 watts

Nov 29, 2008 | Asrock K7S41GX Motherboard

2 Answers

Cannot turn on motherboard


Either the power button itself is bad, or the mainboard is bad. You can test the power supply and mainboard by using a paperclip to short the green wire on the middle of the power connector that goes to the motherboard to the black wire next to it on the same connector. This will force the power supply on. If the mainboard still won't do anything, then it's dead, Jim.

Hope this helps!

Jan 31, 2008 | Asrock P4I45GV R5 Motherboard

1 Answer

My computer shuts down after 3 secs


Try to separate the power cord of your monitor from your system or maybe if your using UPS(uninterrupted power supply) directly plug the UPS to the wall outlet. either you can use pretty voltage regulator to the regulate the AC power.
if not solve the problem try to examine the your system power supply.

Dec 11, 2007 | Computers & Internet

2 Answers

Asrock k7s41gx


it seems to me its a dust problem. any beeps?

Sep 13, 2007 | Asrock Motherboard K7S41GX for AMD...

Not finding what you are looking for?
Asrock K7S41GX Motherboard Logo

Related Topics:

873 people viewed this question

Ask a Question

Usually answered in minutes!

Top Asrock Computers & Internet Experts

Ekse

Level 3 Expert

13434 Answers

Thomas F. Schneider

Level 3 Expert

2715 Answers

Joe Negus
Joe Negus

Level 2 Expert

652 Answers

Are you an Asrock Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...