Question about Pool & Spa

2 Answers

I have a 2010 Viking Destiny River hot tub. When you press the light button, the LED lights do not light up at all - none of them!

When I press the light button on the topside panel, I can hear the relay click inside the main box. Took off the topside panel and you can see inside that the button does work but the indicator light on the panel does not light when you push the light button. But this indicator does light when doing other functions (e.g. changing water temp). Help! Is this a bad panel button, or it internal wiring problem? None of the LED lights work ever!

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a old destiny river hot tub. The lights stopped working suddenly. I can hear a click every time I'm pressing the lights button. That probably means that a relay is clicking so the panel button is working well. But my question is do LEDs are connected in parallel or series? If series if one LED fails all of them will not work (good luck to find the bad one). Anyone have an idea?

Posted on Oct 20, 2019

Ad

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Pool & Spa Master
  • 10,627 Answers

See if voltage past switch if to lights bad lights if no voltage past relay bad relay or switch

Posted on Sep 13, 2018

Ad

2 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Mike Tellegen

  • 1631 Answers

SOURCE: Viking Destiny River 2013 hot tub led tub lights not working. Can hear relay engage when pressing lights on control panel. All not working.

Not exactly sure of your question?
If you pressed 'Light' button on topside control, do any lights come on, some lights, or No lights? Does the light 'Icon' come on, on the topside?
if there is an indicator on the topside that comes on when you press the appropriate button, then the communication between the topside and circuit board have been completed, and that action should work, in your case, the light should come on. If no indicator, that means circuit board received no communication to power the light (s). So... you hear a click? So do you also an indicator that lights should be on, if so - no lights are working, wire to light fixture is either unplugged, or light or lights are burned out, or bad wire connection.
if no indicator on topside control panel = Bad/dead light 'Button', which means bad panel - since you can't repair a button on a topside control panel.

Posted on Apr 10, 2015

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Viking Destiny River 2013 hot tub led tub lights not working. Can hear relay engage when pressing lights on control panel. All not working.


Not exactly sure of your question?
If you pressed 'Light' button on topside control, do any lights come on, some lights, or No lights? Does the light 'Icon' come on, on the topside?
if there is an indicator on the topside that comes on when you press the appropriate button, then the communication between the topside and circuit board have been completed, and that action should work, in your case, the light should come on. If no indicator, that means circuit board received no communication to power the light (s). So... you hear a click? So do you also an indicator that lights should be on, if so - no lights are working, wire to light fixture is either unplugged, or light or lights are burned out, or bad wire connection.
if no indicator on topside control panel = Bad/dead light 'Button', which means bad panel - since you can't repair a button on a topside control panel.

Apr 10, 2015 | Pool & Spa

1 Answer

Maytag skybox stopped cooling Skybox stopped cooling. Sounds like the relay will kick on briefly and then click off. Everything else works. I took the back panel off and could hear the relay clicking on...


The relay on your box is damaged.. You have to get it replaced.. Not to be tried by a novice but if you have some experience in electronics it can be fixed by you. The relay costs around 75$. Good luck!

Mar 26, 2008 | Maytag SkyBox MBV1976A Beverage Dispenser

2 Answers

Sparform hot tub blower won't turn off


When an appliance will not turn off, no matter what you press on the control panel, you have either a non responding (dead button) topside control panel, or your topside panel did receive the message to turn it off and the circuit board is not responding.
  • If you have some kind of indicator light when you press your Jet/pump button, if the topside panel is operational and does actually receive your request to either turn on or off an appliance, an indicator will appear - either a light or icon.
    • If one does appear when button pressed, then dis-appears when pressed, that means your panel is good - as it is responding to the pressing of the associated button.
      • Bad circuit board
    • If nothing appears when you press the button, no lights or icons - indication of topside receiving your request, then you you have a dead button.
      • Bad Topside Control Panel

May 18, 2014 | Dream Maker Spas Dream Maker Ez Spa Hot...

1 Answer

2005 sierra horns stopped working. I hear a click at the fuse box under the hood when i press horn. I know horns are good as i wired them direct. is there another fuse somewhere other than in the fuse box...


The click you hear is the horn relay -- this likely has either dirty / corroded connections or burned contacts inside the relay. If cleaning all relevant connections doesn't solve the problem, replace the relay. You can find the realy by having someone push the horn button while you track down the click.

Charlie

Feb 14, 2011 | GMC Sierra 1500 Cars & Trucks

1 Answer

The topside control panel is dysfunctional for turning on the jets. The on/off button doesn't work. The lights and temperature buttons work ok. The on/off button doesn't click on/off like the others.


It may be a bad control pad (topside) or control box (mounted behind the pump under the tub). I have replaced three bellavista control pad and boxes in the past 2 weeks. If you plan on keeping the tub have both the box and topside replaced. You can check the topside by gently prying it off the tub with a stiff putty knife or a blade of some kind, be very careful and take your time. When you have removed the topside, check the circuit board attached to the cable, if there is any corrosion on the board the topside is bad. It will cost 200.00 less shipping, the control box will cost 320.00 or more less shipping. topside part no. M465000 Control box part no. S474000 Both can be found on the internet under their part numbers.

Mar 13, 2010 | Jacuzzi Bellavista, 5.5ft Soaking Bathtub...

1 Answer

My horn does not work. I press the horn, but all i hear is a click in the fuse box. Checked the fuse and it is good. I bought it from a auction and had problems with the alarm and locking because i didnt...


If the horn fuse ( Fuse #26 ) is installed and has power on both sides of the fuse, you might want to check that the horn connector is still on the horns.

The horn relay is not serviceable in the fuse panel.

You can test the horn connector for power, the Yellow w/ Light Green wire, when the horn button is pressed.

Feb 02, 2010 | 2005 Ford F-150

3 Answers

No power at all. No amber light or green light. Power cord check out fine?? Work great then 8 hours later went to watch TV. and nothing. Any help out there ??


I've been hearing alot about the main power supply board with this model. Mostly I hear that when the power button is pressed, the relay inside will click but with no other response from the TV. This tells me that either the relay contacts are no good or that there are some serious soldering problems on the board. That would explain why it will operate for a short time then quit unexpectedly. Thermal cycling might be stressing the already weak solder joints causing intermittent contact. Personally, I'd love to get my hands on one of these boards.

If it were me and I had nothing to lose, I'd pull the main PS board and touch up the relay section by resoldering (as I believe it is more likely to have bad solder joints then the bad relay contacts). If anyone tries this with positive results, please let me know and rate accordingly.

Dec 29, 2007 | Vizio L37 Television

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

203 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Bill Jordan

Level 2 Expert

375 Answers

john h

Level 3 Expert

22486 Answers

David Spradling
David Spradling

Level 3 Expert

10627 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...