Question about Krell KAV-300i 2-Channel Amplifier

1 Answer

I think maybe the xlr input might be going bad. There's nosie and amplification irregularities coming from one chanel. When I unhook the chanel, it makes a noise( bad connection noise). When I unhook the other chanel, no noise comes out of it. I think it might be an xlr connection that might be going bad.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Expert
  • 120 Answers

Try switching cables from one channel to the other and see if the problem follows the cables.

Posted on Apr 12, 2010

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Behringer PMP1280S INPUT Chanel 1 is no longer working, after pulling out the mic XLR plug whilst the amp was still turned on.


You should be able to unplug a mic from the xlr input with the unit on with no problem.
I beleive the problem is that the xlr input jack has one or more legs broken off the board. If you dsassemble the board and resolder the three legs to the board you'll probably fix the problem.

Dec 01, 2015 | Behringer Music

1 Answer

How come chanel a does not work on the pyle pro pta 1000 is it the way i hooked it up


Without seeing what you have... It comes down to this. Bad amp. Bad input. Switch your RCA cable, if the side is still out.. Unhook speaker, test it with a meter, small batt. Like a 9 volt. If if pops speaker is OK. No pop you have bad speaker, disconnected or bad wire.

Nov 22, 2014 | Audio Players & Recorders

1 Answer

The Clip LED on Channel 1 of my SA220 is on continuously even with nothing plugged in the XLR or 1/4 inch inputs. Not getting amplification when inputs are used. Why?


That light is showing that there is power to amp in that speaker but there is something wrong with the amp or the speaker inside and nothing is coming out. You will have to troubleshoot the amp and check the resistance of the speaker to see what the problem is.

Nov 12, 2014 | Fishman SA220 Solo Performance System...

1 Answer

What would cause my Marshall Mode 4 amp to not change channels?


That can be caused by a faulty switch contact. I presume channels can be selected manually.

Aug 05, 2014 | Marshall Amplification Marshall AR-AM4,...

1 Answer

I have a 2006 cadillac escalade and my speakers went out, they come back on every so often but they stay out for the most part.........i'm thinking it's amplifier.....need some help, what can i do


If you can finder your amplifer check the connections for your wiring. You could jus have a bad ground wire that has a weak connection or a hot wire going to your amplifer that has a bad connection aswell. If it is a bad connection then when you hit bumps going down the road is probably causing them to come on and off without your control.

Sep 07, 2011 | 2006 Cadillac Escalade

1 Answer

Can a technics su v670 be wired up with a technics power amp a800s mk II?? what im thinking it doubles up on the power the wattage to each channels? am i rite? the suv 670 is 90 watts per channel and the...


"im no proffetional at this". Really?

If you looked at the manuals for either product you would NEVER find a recommendation to use one amplifier's speaker input to drive the LINE LEVEL (very small) input on another amplifier. Speaker outputs are for driving speakers or amplifiers designed to accept speaker-level input (like some self-powered subwoofers). In no case is the power of the originating amplifer BOOSTING the power of the driven one.

You should do some reading on how amplifiers work before you blow something up and come asking for advice on how to resolve it.

Sep 02, 2011 | Audio Players & Recorders

3 Answers

Very bad hiss even when power is turned off and battery is removed


If you use a sennheiser check your Squelch is not set to high / low. I use a Z1 and that solved my problem.

Feb 07, 2008 | Sennheiser EW100ENG-G2 2-Way Radio

1 Answer

SR71


I am not sure about this model of mic but it could be as easy as twisting off the bottom. There could also be a screw near the XLR jack that has to be removed, or tightened. Some mics have the XLR jack glued in pretty tightly. I am giving you suggestions based on other mics, I haven't touched a SR71. Hope that helps! Baze

Jun 27, 2007 | Earthworks QTC30 Omni Professional...

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Krell Audio Players & Recorders Experts

80stech

Level 2 Expert

120 Answers

 Grubhead
Grubhead

Level 3 Expert

5699 Answers

Gil Shultz

Level 3 Expert

3388 Answers

Are you a Krell Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...