Question about Dual 2-Channel Bridgeable MOSFET Amplifier (XPA4100) Car Audio Amplifier

1 Answer

My dual amplifier has the red light on and my speaker are not playing

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 45 Answers

One of two things dead shorted speaker in other words blown speaker, or you have an internal problem with the amp due to overheating or overdriving with wrong ohm impedance. shorted transistors hope this helps good luck

Posted on May 25, 2010

Ad

2 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 10 Answers

SOURCE: zx-8100 amplifier is red lighting.

try wiring them differently. here is a link for u to go to http://www.crutchfield.com/learn/learningcenter/car/subwoofers_wiring.html . once there find your amp configuration (ie. mono, or 2 channel) then down to the type of subs an how many subs ( ie. 2 dvc (dual voice coil) 4 ohm subs) an that will show u how the subs should be wired and wired to the amp.

Posted on Apr 04, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subwoofer is not playing


It is hard to say. The sub-woofer has its own amplifier, although it is supplied the sound data from the main amplifier. It could have a problem with the battery power circuit (Sub-Woofer Amplifier Connector Pin 6, LIGHT GREEN/VIOLET) or it could have a problem with the GROUND circuit (Pin 2, BLACK/LIGHT GREEN) Or it could possibly not be receiving the signal from the main amplifier (Pin 7, BROWN/ORANGE "+"), (Pin 8, RED/BLACK "-"). Or it could be that either the sub-woofer speaker is blown, or the sub-woofer amplifier is defective.
There is also a "High Audio Mute" circuit that connects between the main amplifier and the sub-woofer amplifier.

Mar 06, 2012 | 2000 Lincoln Navigator

1 Answer

It has stopped workin and the red light is flashing.Is this a code and if so how do you read it


The red light is a power protection circuit designed to shut the amplifier down due to an overload or wiring problem. If the amp was playing then shut off, my guess is a problem with the speakers or the speaker wiring. Some amplifiers are only stable to a certain load. For example, most car audio speakers are 4 ohms which is the resistance placed upon your amplifier to produce a certain volume of sound. If you bridge two 4 ohm speakers together in parallel, you cut the resistance in half, thus increasing the amount of power (and volume) to your speakers. This also creates more heat and could, in effect, shut your amplifier down. I would find out how the speakers are wired to determine the resistance of the load your amplifier is pushing. Also check the grounding.

May 26, 2011 | MTX X Thunder 300XD Car Amp

1 Answer

Amp wasplaying red light came on and won't go away i check ground and it is good


The red light is a power protection circuit designed to shut the amplifier down due to an overload or wiring problem. If the amp was playing then shut off, my guess is a problem with the speakers or the speaker wiring. Some amplifiers are only stable to a certain load. For example, most car audio speakers are 4 ohms which is the resistance placed upon your amplifier to produce a certain volume of sound. If you bridge two 4 ohm speakers together in parallel, you cut the resistance in half, thus increasing the amount of power (and volume) to your speakers. This also creates more heat and could, in effect, shut your amplifier down. I would find out how the speakers are wired to determine the resistance of the load your amplifier is pushing.

Jun 20, 2010 | MTX Terminator TN400/4 Car Audio Amplifier

1 Answer

Power/protector light changed from green to red and my speakers will not play


does it do it with the speakers disconected? if not you got a dodgy speaker,
if speakers ok and all wiring is correct then its an internal fault most likely

Mar 06, 2010 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

My power indicator light when it first comes on is green and then goes to red and wont play


dissconect your speakers and check the resistance on them you may have blown them

Jan 07, 2010 | Dual XAF-460 Car Audio Amplifier

1 Answer

1994 FORD EXPLOER XLT RADIO CONNECTORS HAVE BEEN CUT OFF


here is wire color diagram.
1994 Ford Explorer Car Stereo Wiring Diagram
Car Radio Battery Constant 12v+ Wire: Light Green/Yellow
Car Radio Accessory Switched 12v+ Wire: Yellow/Black
Car Radio Ground Wire: Red or Black
Car Radio Illumination Wire: Orange/Black
Car Stereo Dimmer Wire: Light Blue/Red
Car Stereo Antenna Trigger Wire: N/A
Car Stereo Amp Trigger Wire: Blue
Car Stereo Amplifier Location: N/A
Car Audio Front Speakers Size: N/A
Car Audio Front Speakers Location: N/A
Left Front Speaker Positive Wire (+): Orange/Light Green
Left Front Speaker Negative Wire (-): Light Blue/White
Right Front Speaker Positive Wire (+): White/Light Green
Right Front Speaker Negative Wire (-): Pink/Light Green
Car Audio Rear Speakers Size: N/A
Car Audio Rear Speakers Location: N/A
Left Rear Speaker Positive Wire (+): Pink/Light Green
Left Rear Speaker Negative Wire (-): Tan/Yellow
Right Rear Speaker Positive Wire (+): Orange/Red

Mar 29, 2009 | 1994 Ford Explorer Limited

1 Answer

New Dual XIA3145 2/1 LED glows red, guide claims speaker problem


look at these and only these... power or ground...either your power wire has grounded out somewhere (ud be surprised) or youdont have a good enough ground....i would check the ground first....hopefully this helps

Jan 27, 2009 | Dual (DBXPA6100) Car Audio Amplifier

1 Answer

Thumping speakers - no power light is on - wired correctly


the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Nov 02, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Amp Power light will not go on. Protection light is lit- Thump sound in speakers


It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Oct 31, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Dual xpa 4100 2/3/4 chanel amp


make sure power and ground are where they are suppose to be and speaker wires are not mixed up. but it sounds to me like the amp is junk

Jun 09, 2008 | Dual 2-Channel Bridgeable MOSFET Amplifier...

Not finding what you are looking for?
Dual 2-Channel Bridgeable MOSFET Amplifier (XPA4100) Car Audio Amplifier Logo

Related Topics:

4,309 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dual Car Audio & Video Experts

Ekse

Level 3 Expert

13434 Answers

Marvin
Marvin

Level 3 Expert

85216 Answers

Larry Tezekjian
Larry Tezekjian

Level 2 Expert

117 Answers

Are you a Dual Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...